summaryrefslogtreecommitdiff
path: root/games-engines/love/love-11.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 14:59:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 14:59:08 +0100
commit1503b28e7a30c164cab750c27268f704b8a5cec6 (patch)
treed06a47a18b0fb792e95f88ea6e18af234eb0b9d5 /games-engines/love/love-11.4.ebuild
parent34ce8f465101950c92cb66c657d3244b5a8397db (diff)
gentoo auto-resync : 26:07:2022 - 14:59:07
Diffstat (limited to 'games-engines/love/love-11.4.ebuild')
-rw-r--r--games-engines/love/love-11.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-engines/love/love-11.4.ebuild b/games-engines/love/love-11.4.ebuild
index fcc2e07df8e9..5cb3aaec9bc9 100644
--- a/games-engines/love/love-11.4.ebuild
+++ b/games-engines/love/love-11.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
LUA_COMPAT=( lua5-{1..4} luajit )
-inherit lua-single xdg-utils
+inherit flag-o-matic lua-single xdg-utils
if [[ ${PV} == 9999* ]]; then
inherit git-r3
@@ -47,6 +47,9 @@ src_prepare() {
}
src_configure() {
+ # Bug #858719
+ append-flags -fno-strict-aliasing
+
local myeconfargs=(
$(use_enable gme)
--with-lua=$(usex lua_single_target_luajit luajit lua)