summaryrefslogtreecommitdiff
path: root/games-engines/love/love-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /games-engines/love/love-9999.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'games-engines/love/love-9999.ebuild')
-rw-r--r--games-engines/love/love-9999.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/games-engines/love/love-9999.ebuild b/games-engines/love/love-9999.ebuild
deleted file mode 100644
index 80ae23fbd24b..000000000000
--- a/games-engines/love/love-9999.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit base games
-
-if [[ ${PV} == 9999* ]]; then
- inherit autotools mercurial
- EHG_REPO_URI="https://bitbucket.org/rude/${PN}"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="A framework for 2D games in Lua"
-HOMEPAGE="http://love2d.org/"
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-games/physfs
- dev-lang/lua[deprecated]
- media-libs/devil[mng,png,tiff]
- media-libs/freetype
- media-libs/libmodplug
- media-libs/libsdl[joystick,opengl]
- media-libs/libvorbis
- media-libs/openal
- media-sound/mpg123
- virtual/opengl"
-DEPEND="${RDEPEND}
- media-libs/libmng
- media-libs/tiff"
-
-DOCS=( "readme.md" "changes.txt" )
-
-src_prepare() {
- if [[ ${PV} == 9999* ]]; then
- sh platform/unix/gen-makefile || die
- cp platform/unix/Makefile.am . || die
- cp platform/unix/configure.ac . || die
- mkdir platform/unix/m4 || die
- eautoreconf
- fi
-}
-
-src_install() {
- base_src_install
- if [[ "${SLOT}" != "0" ]]; then
- mv "${ED}${GAMES_BINDIR}"/${PN} \
- "${ED}${GAMES_BINDIR}"/${PN}-${SLOT} || die
- fi
-}