summaryrefslogtreecommitdiff
path: root/games-engines/scummvm/scummvm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /games-engines/scummvm/scummvm-9999.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'games-engines/scummvm/scummvm-9999.ebuild')
-rw-r--r--games-engines/scummvm/scummvm-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/games-engines/scummvm/scummvm-9999.ebuild b/games-engines/scummvm/scummvm-9999.ebuild
index cf7685a08e01..9f70736f67ee 100644
--- a/games-engines/scummvm/scummvm-9999.ebuild
+++ b/games-engines/scummvm/scummvm-9999.ebuild
@@ -11,14 +11,14 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scummvm/scummvm"
else
- SRC_URI="https://scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+ SRC_URI="https://downloads.scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
S="${WORKDIR}/${PN}-${P}"
fi
LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
SLOT="0"
-IUSE="a52 aac alsa debug flac fluidsynth fribidi glew +gtk jpeg lua mpeg2 mp3 +net opengl png sndio speech theora truetype unsupported vorbis zlib"
+IUSE="a52 aac alsa debug flac fluidsynth fribidi gif glew +gtk jpeg lua mpeg2 mp3 +net opengl png sndio speech theora truetype unsupported vorbis zlib"
RESTRICT="test" # it only looks like there's a test there #77507
RDEPEND="
@@ -29,6 +29,7 @@ RDEPEND="
flac? ( media-libs/flac )
fluidsynth? ( media-sound/fluidsynth:= )
fribidi? ( dev-libs/fribidi )
+ gif? ( media-libs/giflib )
gtk? (
dev-libs/glib:2
x11-libs/gtk+:3
@@ -102,6 +103,7 @@ src_configure() {
$(use_enable flac)
$(usex fluidsynth '' --disable-fluidsynth)
$(use_enable fribidi)
+ $(use_enable gif)
$(use opengl && use_enable glew)
$(use_enable gtk)
$(use_enable jpeg)