summaryrefslogtreecommitdiff
path: root/games-fps/alephone-marathon/alephone-marathon-20220115.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-30 04:47:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-30 04:47:47 +0100
commit048bd060badd229e3bb596029874760a86d27060 (patch)
tree255c77a2abedb5474cd77d0b3cac24551de7771d /games-fps/alephone-marathon/alephone-marathon-20220115.ebuild
parent8993ea73a9714d22178ba6ada8c04be83cd71ec7 (diff)
gentoo auto-resync : 30:08:2022 - 04:47:47
Diffstat (limited to 'games-fps/alephone-marathon/alephone-marathon-20220115.ebuild')
-rw-r--r--games-fps/alephone-marathon/alephone-marathon-20220115.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-fps/alephone-marathon/alephone-marathon-20220115.ebuild b/games-fps/alephone-marathon/alephone-marathon-20220115.ebuild
new file mode 100644
index 000000000000..a1a96ad86ae5
--- /dev/null
+++ b/games-fps/alephone-marathon/alephone-marathon-20220115.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon (M1A1)"
+HOMEPAGE="http://marathon.sourceforge.net/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/Marathon-${PV}-Data.zip"
+S="${WORKDIR}/Marathon"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="marathon"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}