summaryrefslogtreecommitdiff
path: root/games-fps/industri/industri-1.01.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-fps/industri/industri-1.01.ebuild
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/industri/industri-1.01.ebuild')
-rw-r--r--games-fps/industri/industri-1.01.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/games-fps/industri/industri-1.01.ebuild b/games-fps/industri/industri-1.01.ebuild
deleted file mode 100644
index 70c8dba417f3..000000000000
--- a/games-fps/industri/industri-1.01.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils toolchain-funcs games
-
-DESCRIPTION="Quake/Tenebrae based, single player game"
-HOMEPAGE="http://industri.sourceforge.net/"
-SRC_URI="mirror://sourceforge/industri/industri_BIN-${PV}-src.tar.gz
- mirror://sourceforge/industri/industri-1.00.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="cdinstall"
-
-RDEPEND="virtual/opengl
- x11-libs/libXxf86dga
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXxf86vm
- media-libs/libpng:0
- cdinstall? ( games-fps/quake1-data )"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
- app-arch/unzip"
-
-S=${WORKDIR}/industri_BIN
-
-src_prepare() {
- mv linux/Makefile{.i386linux,}
- sed -i -e "s:-mpentiumpro.*:${CFLAGS} \\\\:" linux/Makefile || die
-
- # Remove duplicated typedefs #71841
- for typ in PFNGLFLUSHVERTEXARRAYRANGEAPPLEPROC PFNGLVERTEXARRAYRANGEAPPLEPROC ; do
- if echo '#include <GL/gl.h>' | $(tc-getCC) -E - 2>/dev/null | grep -sq ${typ} ; then
- sed -i \
- -e "/^typedef.*${typ}/d" \
- glquake.h || die
- fi
- done
-
- sed -i \
- -e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:g' \
- gl_warp.c || die
-
- epatch "${FILESDIR}"/${P}-exec-stack.patch \
- "${FILESDIR}"/${P}-ldflags.patch \
- "${FILESDIR}"/${P}-glext.patch
-}
-
-src_compile() {
- emake \
- -C linux \
- MASTER_DIR="${GAMES_DATADIR}"/quake1 \
- build_release
-}
-
-src_install() {
- newgamesbin linux/release*/bin/industri.run industri
- dogamesbin "${FILESDIR}"/industri.pretty
- insinto /usr/share/icons
- doins industri.ico quake.ico
- dodoc linux/README
- cd "${WORKDIR}"/${PN}
- dodoc *.txt
- insinto "${GAMES_DATADIR}"/quake1/${PN}
- doins *.pak *.cfg
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- if ! use cdinstall ; then
- elog "You need to copy pak0.pak to ${GAMES_DATADIR}/quake1 to play."
- fi
-}