summaryrefslogtreecommitdiff
path: root/games-fps/legends/legends-0.4.1.43-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-fps/legends/legends-0.4.1.43-r2.ebuild
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/legends/legends-0.4.1.43-r2.ebuild')
-rw-r--r--games-fps/legends/legends-0.4.1.43-r2.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/games-fps/legends/legends-0.4.1.43-r2.ebuild b/games-fps/legends/legends-0.4.1.43-r2.ebuild
deleted file mode 100644
index 0412178e3f4b..000000000000
--- a/games-fps/legends/legends-0.4.1.43-r2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils unpacker
-
-MY_P=${PN}_linux-${PV}
-dir=/opt/${PN}
-
-DESCRIPTION="Fast-paced first-person-shooter online multiplayer game, similar to Tribes"
-HOMEPAGE="http://legendsthegame.net/"
-SRC_URI="http://legendsthegame.net/files/${MY_P}.run
- mirror://gentoo/${PN}.png"
-
-LICENSE="Legends LGPL-2.1+"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="+dedicated"
-RESTRICT="strip"
-
-QA_TEXTRELS="${dir:1}/libSDL-1.3.so.0"
-QA_FLAGS_IGNORED="${dir:1}/libSDL-1.3.so.0 ${dir:1}/LinLegends ${dir:1}/lindedicated"
-
-DEPEND=""
-RDEPEND="sys-libs/glibc
- amd64? ( sys-libs/glibc[multilib] )
- media-fonts/font-adobe-75dpi
- media-libs/libsdl[video,sound,opengl,abi_x86_32(-)]
- x11-libs/libX11[abi_x86_32(-)]
- x11-libs/libXext[abi_x86_32(-)]
- media-libs/libogg[abi_x86_32(-)]
- media-libs/libvorbis[abi_x86_32(-)]
- media-libs/openal[abi_x86_32(-)]"
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack_makeself ${MY_P}.run
- cd "${S}"
-
- # keep libSDL-1.3.so because legends requires it as of 0.4.0, and
- # 1.2.6 is highest in portage
- # rm libSDL-*.so*
- rm runlegends libSDL-1.2.so.0 libopenal.so libogg.so.0 libvorbis.so.0 *.DLL || die
-}
-
-src_install() {
- insinto "${dir}"
- doins -r * || die "doins * failed"
-
- rm "${D}/${dir}/"/{lindedicated,LinLegends,*.so.0}
- exeinto "${dir}"
- doexe lindedicated LinLegends *.so.0 || die "doexe failed"
-
- make_wrapper ${PN} "./LinLegends" "${dir}" "${dir}"
- if use dedicated ; then
- make_wrapper ${PN}-ded "./lindedicated" "${dir}" "${dir}"
- fi
-
- doicon "${DISTDIR}"/${PN}.png || die "doicon failed"
- make_desktop_entry legends "Legends"
-}
-
-pkg_postinst() {
- ewarn "Version ${PV} of ${PN} may give problems if there are"
- ewarn "config-files from earlier versions. Removing the ~/.legends dir"
- ewarn "and restarting will solve this."
- echo
-}