summaryrefslogtreecommitdiff
path: root/games-fps/quake1-killer/quake1-killer-2.2z-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-fps/quake1-killer/quake1-killer-2.2z-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-fps/quake1-killer/quake1-killer-2.2z-r1.ebuild')
-rw-r--r--games-fps/quake1-killer/quake1-killer-2.2z-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-fps/quake1-killer/quake1-killer-2.2z-r1.ebuild b/games-fps/quake1-killer/quake1-killer-2.2z-r1.ebuild
new file mode 100644
index 000000000000..f7b2c4a6652c
--- /dev/null
+++ b/games-fps/quake1-killer/quake1-killer-2.2z-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The Killer Quake Patch"
+HOMEPAGE="http://kqp.horoy.com/"
+SRC_URI="http://www.gamers.org/pub/idgames2/quakec/compilations/kqp220z.zip
+ mirror://gentoo/kqp220z.zip"
+S="${WORKDIR}"
+
+LICENSE="quake1-killer"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+src_unpack() {
+ elog "Unpacking kqp220z.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/kqp220z.zip || die "unpacking kqp220z.zip failed"
+}
+
+src_install() {
+ insinto /usr/share/quake1/killer
+ doins -r *
+}