summaryrefslogtreecommitdiff
path: root/games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild')
-rw-r--r--games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild b/games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild
new file mode 100644
index 000000000000..5b4137c84763
--- /dev/null
+++ b/games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit edos2unix
+
+DESCRIPTION="TC which turns Quake into a Rally racing game"
+HOMEPAGE="http://wiki.quakeworld.nu/Quake_Rally"
+SRC_URI="http://ehall.freeshell.org/quake/qr12.zip
+ http://ehall.freeshell.org/quake/qrlo1.zip"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="mirror bindist"
+
+BDEPEND="app-arch/unzip"
+
+src_unpack() {
+ einfo "Unpacking qr12.zip to ${PWD}"
+ unzip -qoLL "${DISTDIR}"/qr12.zip || die "unpacking qr12.zip failed"
+
+ einfo "Unpacking qrlo1.zip to ${PWD}"
+ unzip -qoLL "${DISTDIR}"/qrlo1.zip || die "unpacking qrlo1.zip failed"
+
+ rm -f button.wav qrally.exe || die
+ cd rally || die
+
+ edos2unix $(find . -name '*.txt' -o -name '*.cfg' || die)
+ mv rally{,.example}.cfg || die
+}
+
+src_install() {
+ insinto /usr/share/quake1
+ doins -r *
+}