summaryrefslogtreecommitdiff
path: root/games-fps/serioussam
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-27 01:38:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-27 01:38:47 +0000
commita2210d6624510ad5825191a26603b73bbc096b98 (patch)
tree532ae6f32e362993fd926b040ad57cabe1c8d4e8 /games-fps/serioussam
parent7ab79528a3e9a77497eb58022bb0e775e7440885 (diff)
gentoo auto-resync : 27:12:2023 - 01:38:47
Diffstat (limited to 'games-fps/serioussam')
-rw-r--r--games-fps/serioussam/Manifest3
-rw-r--r--games-fps/serioussam/metadata.xml22
-rw-r--r--games-fps/serioussam/serioussam-1.10.6.ebuild106
3 files changed, 131 insertions, 0 deletions
diff --git a/games-fps/serioussam/Manifest b/games-fps/serioussam/Manifest
new file mode 100644
index 000000000000..d2a7641c9520
--- /dev/null
+++ b/games-fps/serioussam/Manifest
@@ -0,0 +1,3 @@
+DIST serioussam-1.10.6c.tar.gz 47908208 BLAKE2B 90af9f8c11b474ce0e114c3390e1afd5c746c1b2ca4e61bd6085f1dc42f6f73981cc4434ff8fdcc1306178ae9d2707026765a3a1da006d5adb841d2d314a4214 SHA512 de1ba536c84977d1e7335833b8a2080b13a22ca25efba88363972dceb4bcbfda1db448de42d262fa003fe9df393327509e76afc3cc501f96ed6495d29b74b6bb
+EBUILD serioussam-1.10.6.ebuild 3053 BLAKE2B 02bfe75c9f094a5a4b29592ff652f62bc010120c19838b4bd396f1a26b894c7ed7425023cf458503056d315411becd47d0fdef4ca1672e9ec5c3e4443a480c5b SHA512 a29ce2a5bd037fd49a04e858363044b22c41541ce00aa2debcff31b358cd31f382deb0b887bd3efadc9d5e124dd3e01f125dc8800457f88cd7868cffbb44df49
+MISC metadata.xml 846 BLAKE2B 59dd6e1ebcb1b9e4c19271f53f8564a003b78627640312b18a0e52b686d59878b6b00fd946803df40c8b4a9e60fcc85886d11d318c3f0d4be3544aa5d9f4be9b SHA512 80a0b25d6d0f2dd23b030179e17c55d6d8b42b5bd8aa68103eee6250e228d0860d35d8b98e6c833156ee0fbe7b2663a988469362631ce218a657f742b8463a91
diff --git a/games-fps/serioussam/metadata.xml b/games-fps/serioussam/metadata.xml
new file mode 100644
index 000000000000..c9c22cde71e7
--- /dev/null
+++ b/games-fps/serioussam/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>t.x00100x.t@yandex.ru</email>
+ <name>Alexander Pavlov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="alsa">Enable support ALSA sound.</flag>
+ <flag name="pipewire">Enable support for pipewire.</flag>
+ <flag name="vulkan">Enable support Vulkan render.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">tx00100xt/SeriousSamClassic-VK</remote-id>
+ <bugs-to>https://github.com/tx00100xt/SeriousSamClassic-VK/issues</bugs-to>
+ <changelog>https://github.com/tx00100xt/SeriousSamClassic-VK/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/serioussam/serioussam-1.10.6.ebuild b/games-fps/serioussam/serioussam-1.10.6.ebuild
new file mode 100644
index 000000000000..5b9b2d1a433d
--- /dev/null
+++ b/games-fps/serioussam/serioussam-1.10.6.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop
+
+MY_PN1="SamTFE"
+MY_PN2="SamTSE"
+# Game name
+GN1="serioussam"
+GN2="serioussamse"
+
+DESCRIPTION="Linux port of Serious Sam Classic with Vulkan support"
+HOMEPAGE="https://github.com/tx00100xt/SeriousSamClassic-VK"
+SRC_URI="https://github.com/tx00100xt/SeriousSamClassic-VK/archive/refs/tags/${PV}c.tar.gz -> ${P}c.tar.gz"
+S="${WORKDIR}/SeriousSamClassic-VK-${PV}c"
+
+MY_CONTENT1="${WORKDIR}/SeriousSamClassic-VK-${PV}c/${MY_PN1}"
+MY_CONTENT2="${WORKDIR}/SeriousSamClassic-VK-${PV}c/${MY_PN2}"
+
+LICENSE="GPL-2 BSD ZLIB"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa pipewire vulkan"
+
+RDEPEND="
+ games-fps/serioussam-tfe-data
+ games-fps/serioussam-tse-data
+ media-libs/libsdl2[video,joystick,opengl]
+ media-libs/libvorbis
+ sys-libs/zlib
+ alsa? (
+ >=media-libs/libsdl2-2.0.6[alsa,sound]
+ )
+ pipewire? (
+ >=media-libs/libsdl2-2.0.6[pipewire,sound]
+ )
+ vulkan? (
+ dev-util/vulkan-headers
+ media-libs/vulkan-loader
+ media-libs/libsdl2[video,joystick,opengl,vulkan]
+ )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ sys-devel/flex
+ sys-devel/bison
+ media-gfx/imagemagick
+"
+
+src_configure() {
+ einfo "Remove Win32 stuff..."
+ rm -rf "${MY_CONTENT1}"/Tools.Win32 || die "Failed to remove stuff Win32"
+ rm -rf "${MY_CONTENT2}"/Tools.Win32 || die "Failed to remove stuff Win32"
+
+ einfo "Setting build type Release..."
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(
+ -DUSE_SYSTEM_INSTALL=ON
+ -DUSE_SYSTEM_VULKAN=$(usex vulkan ON OFF)
+ -DUSE_ASM=$(usex x86 OFF ON)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ local dir1="/usr/share/${GN1}"
+ local dir2="/usr/share/${GN2}"
+ local dir3="/usr/share/applications"
+ cmake_src_install
+
+ # install man pages
+ mv "${S}"/man/gentoo/serioussam-vk.1 "${S}"/man/gentoo/serioussam.1 \
+ || die "Failed move man pages"
+ doman "${S}"/man/gentoo/serioussam.1
+
+ # removing repo stuff
+ rm -fr "${MY_CONTENT1}/Sources" && rm -fr "${MY_CONTENT2}/Sources" \
+ || die "Failed to remove Sources"
+ rm -f "${MY_CONTENT1}"/{*.png,*.desktop} \
+ || die "Failed to remove serioussam icon and desktop file"
+ rm -f "${MY_CONTENT2}"/{*.png,*.desktop} \
+ || die "Failed to remove serioussamse icon and desktop file"
+ rm -f "${ED}${dir3}/${GN1}.desktop" "${ED}${dir3}/${GN2}.desktop" \
+ || die "Failed to remove desktop file"
+
+ # moving repo content (Scripts, Data, Settings ...)
+ cp -fr "${MY_CONTENT1}"/* "${ED}${dir1}" \
+ || die "Failed to copy repo content (Scripts, Settings)"
+ cp -fr "${MY_CONTENT2}"/* "${ED}${dir2}" \
+ || die "Failed to copy repo content (Scripts, Settings)"
+
+ make_desktop_entry ${GN1} "Serious Sam The First Encounter" ${GN1}
+ make_desktop_entry ${GN2} "Serious Sam The Second Encounter" ${GN2}
+}
+
+pkg_postinst() {
+ elog " Look at:"
+ elog " man serioussam"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK/wiki"
+ elog " For information on the first launch of the game"
+}