summaryrefslogtreecommitdiff
path: root/games-fps/tribes2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/tribes2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/tribes2')
-rw-r--r--games-fps/tribes2/Manifest3
-rw-r--r--games-fps/tribes2/metadata.xml8
-rw-r--r--games-fps/tribes2/tribes2-25034.ebuild76
3 files changed, 87 insertions, 0 deletions
diff --git a/games-fps/tribes2/Manifest b/games-fps/tribes2/Manifest
new file mode 100644
index 000000000000..5d06ddab1330
--- /dev/null
+++ b/games-fps/tribes2/Manifest
@@ -0,0 +1,3 @@
+DIST tribes2-25034-cdrom-x86.run 95560158 BLAKE2B a4516fddde83a8623348557983b3b5592c24108805da521d1b24bee21c06f8300ca812db8533855b70d924c59cf2bf417a771daa417c7f9b79e39f34a3611f98 SHA512 a3d2800af06d8659193ed1da4b9042af0924e1a0ade8a410aec31d66591efa2d2773aa12b33f7234975efee083974a77434bb1c0124bd57bfcc3be4898c46ad8
+EBUILD tribes2-25034.ebuild 2122 BLAKE2B 56abbd3c628f94595c2eb2415b8fd344f446bc71398f144bf3c092f7896f223ac0512315b83c2faef56fb9f9b7f9915505bcf8cd6d72387e2eaea330801ad344 SHA512 acfc53599d9754d526975641040b6cb520ffd7e2435eb0637df4a319d35db1900d76f4bc6c103f4e2dfeae8e67488bc0944384fa605978f51c4932f253d564db
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/tribes2/metadata.xml b/games-fps/tribes2/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/tribes2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/tribes2/tribes2-25034.ebuild b/games-fps/tribes2/tribes2-25034.ebuild
new file mode 100644
index 000000000000..817ede1c3913
--- /dev/null
+++ b/games-fps/tribes2/tribes2-25034.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker cdrom games
+
+DESCRIPTION="Tribes 2 - Team Combat on an Epic Scale"
+HOMEPAGE="http://www.lokigames.com/products/tribes2/"
+SRC_URI="http://www.libsdl.org/projects/${PN}/release/${P}-cdrom-x86.run
+ mirror://3dgamers/${PN}/${P}-cdrom-x86.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+# This package is broken and doesn't patch right on AMD64. I've not taken the
+# time to try to figure it out but this definitely needs to stay -amd64 until
+# someone does fix the patching.
+KEYWORDS="-amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+
+DEPEND="sys-libs/glibc
+ games-util/loki_patch"
+RDEPEND="${DEPEND}
+ virtual/opengl"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ games_pkg_setup
+ ewarn "The installed game takes about 507MB of space!"
+}
+
+src_unpack() {
+ cdrom_get_cds README.tribes2d
+ unpack_makeself
+}
+
+src_install() {
+ einfo "Copying files... this may take a while..."
+ exeinto "${dir}"
+ doexe "${CDROM_ROOT}"/bin/x86/glibc-2.1/{t2launch,tribes2,tribes2.dynamic,tribes2d,tribes2d-restart.sh,tribes2d.dynamic}
+
+ insinto "${dir}"
+ doins "${CDROM_ROOT}"/{README,README.tribes2d,Tribes2_Manual.pdf,console_start.cs,kver.pub} "${Ddir}"
+
+ # Video card profiles
+ # TODO: move this to src_unpack where it belongs.
+ tar xzf ${CDROM_ROOT}/profiles.tar.gz -C "${Ddir}" || die
+
+ # Base (Music, Textures, Maps, etc.)
+ doins -r ${CDROM_ROOT}/base ${CDROM_ROOT}/menu
+
+ cd "${S}"
+ loki_patch --verify patch.dat
+ loki_patch patch.dat "${Ddir}" >& /dev/null || die
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find "${Ddir}" -exec touch '{}' +
+
+ newicon "${CDROM_ROOT}"/icon.xpm tribes2.xpm
+ games_make_wrapper t2launch ./t2launch "${dir}" "${dir}"
+ make_desktop_entry t2launch "Tribes 2" tribes2
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To play the game run:"
+ elog " t2launch"
+}