summaryrefslogtreecommitdiff
path: root/games-fps/ut2003-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-fps/ut2003-data
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-fps/ut2003-data')
-rw-r--r--games-fps/ut2003-data/Manifest2
-rw-r--r--games-fps/ut2003-data/ut2003-data-2107-r2.ebuild (renamed from games-fps/ut2003-data/ut2003-data-2107.ebuild)55
2 files changed, 38 insertions, 19 deletions
diff --git a/games-fps/ut2003-data/Manifest b/games-fps/ut2003-data/Manifest
index 33a3ece6c38e..fdab44b67aa4 100644
--- a/games-fps/ut2003-data/Manifest
+++ b/games-fps/ut2003-data/Manifest
@@ -1,3 +1,3 @@
DIST UT2003CrashFix.zip 2764 BLAKE2B 697c35a02f447d0d436fc32bebdeafbca55ef644d951e92085c33f7597108625770b76e027f31287cd2ac66607692ff8c908f6971f936a134d58d0effc2586fc SHA512 24fdaac873b08a0860c23f66b9bd93922fc4f64486adbe9bfefeb340f9d9374778b5e7bacd0e12cc79d819fb340e007ab2a7f1f45c9e4f27ab3ab6b11033d444
-EBUILD ut2003-data-2107.ebuild 3980 BLAKE2B 502c326854ab6ccf87a186f8cf48db17e2c6abfdc8ebb572ad42d5fff49fbeb7fc5cf89e779a2017de5694af34bf3b16045f27a111c97d9c9c6977a19f0a36ba SHA512 8e5438a5e638399e14fec83a5c397a6f718c15d38d5228bc86c911a71b1a1a7fd8f9a239cd6384bb79c73d6c5e873f21e15edf159b30ae53d809f97ffc0804e0
+EBUILD ut2003-data-2107-r2.ebuild 4563 BLAKE2B 7c4c621ed4afe06ac018ee18dae3eddd68839baa491dd0594fd7c77aae3b9394bc3138c1a4da50a6ec421b4c2ec4d5fce3a93a50fa8544c63034ac2b163c4ff7 SHA512 f72fb4f1ad49fbc7e1a307484683844106ca29b5e94e7b124af9803c2ccabe3cbea2385d4331c79cd221d4fa3e1cb04db2f2b3e89f5e3aa143667729b4111f45
MISC metadata.xml 771 BLAKE2B 705c6aa979f650220a52db3ef5d8c5b8b468b28eac8692a2fbe583ed4b3f694fdfe088d64cc3f6d8506494522f8ca11b491e21e322e3f50ff4453e93ce0d543f SHA512 d30d55503e3b3897d2a5093c06a39f684bdf0879214931a360a87637cd62ae1ca019577f42275bf2b4ba28649ab2989b0a2e184998497ddc5ffddbb6ba35ef5e
diff --git a/games-fps/ut2003-data/ut2003-data-2107.ebuild b/games-fps/ut2003-data/ut2003-data-2107-r2.ebuild
index 44433cc98f3e..ac69da5ef178 100644
--- a/games-fps/ut2003-data/ut2003-data-2107.ebuild
+++ b/games-fps/ut2003-data/ut2003-data-2107-r2.ebuild
@@ -1,30 +1,30 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils unpacker cdrom games
+EAPI=7
+
+inherit desktop cdrom unpacker
DESCRIPTION="Unreal Tournament 2003 - Sequel to the 1999 multi-player first-person shooter"
HOMEPAGE="http://www.unrealtournament2003.com/"
SRC_URI="https://dev.gentoo.org/~chewi/distfiles/UT2003CrashFix.zip" # MIT licensed (bug #754360)
+S="${WORKDIR}"
LICENSE="ut2003 MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RESTRICT="bindist strip"
-
-RDEPEND=""
-DEPEND="app-arch/unzip
- games-util/uz2unpack"
+RESTRICT="bindist mirror strip"
-S=${WORKDIR}
+BDEPEND="
+ app-arch/unzip
+ games-util/uz2unpack
+"
-dir=${GAMES_PREFIX_OPT}/ut2003
-Ddir=${D}/${dir}
+dir=opt/ut2003
+Ddir="${ED}"/${dir}
pkg_setup() {
- games_pkg_setup
ewarn "The installed game takes about 2.7GB of space!"
}
@@ -35,6 +35,27 @@ src_unpack() {
}
src_install() {
+ # Inlined from games.eclass
+ _games_ut_unpack() {
+ local ut_unpack="${1}"
+ local f=
+
+ if [[ -z ${ut_unpack} ]] ; then
+ die "You must provide an argument to games_ut_unpack"
+ fi
+
+ if [[ -f ${ut_unpack} ]] ; then
+ uz2unpack "${ut_unpack}" "${ut_unpack%.uz2}" || die "failed uncompressing file ${ut_unpack}"
+ fi
+
+ if [[ -d ${ut_unpack} ]] ; then
+ while read f ; do
+ uz2unpack "${ut_unpack}/${f}" "${ut_unpack}/${f%.uz2}" || die "failed uncompressing file ${f}"
+ rm -f "${ut_unpack}/${f}" || die "failed deleting compressed file ${f}"
+ done < <(find "${ut_unpack}" -maxdepth 1 -name '*.uz2' -printf '%f\n' 2>/dev/null)
+ fi
+ }
+
insinto "${dir}"
# Disk 1
einfo "Copying files from Disk 1..."
@@ -83,7 +104,7 @@ src_install() {
insinto "${dir}"/System
doins "${S}"/System/Def{ault,User}.ini
- # install eula
+ # install EULA
insinto "${dir}"
doins "${S}"/eula/License.int
@@ -98,19 +119,19 @@ src_install() {
# uncompressing files
einfo "Uncompressing files... this may take a while..."
for j in {Animations,Maps,Sounds,StaticMeshes,Textures} ; do
- games_ut_unpack "${Ddir}"/${j} || die "uncompressing files"
+ _games_ut_unpack "${Ddir}"/${j} || die "uncompressing files"
done
# installing documentation/icon
dodoc "${S}"/README.linux
- newicon "${S}"/Unreal.xpm ut2003.xpm || die "copying icon"
+ newicon "${S}"/Unreal.xpm ut2003.xpm
doins "${S}"/README.linux "${S}"/Unreal.xpm
# copy ut2003/ucc
exeinto "${dir}"
doexe "${S}"/bin/ut2003 "${S}"/ucc
# Here we apply DrSiN's crash patch
- cp "${S}"/CrashFix/System/crashfix.u "${Ddir}"/System
+ cp "${S}"/CrashFix/System/crashfix.u "${Ddir}"/System || die
ed "${Ddir}"/System/Default.ini >/dev/null 2>&1 <<EOT
$
@@ -130,6 +151,4 @@ EOT
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
find "${Ddir}" -exec touch '{}' + || die
-
- prepgamesdirs
}