summaryrefslogtreecommitdiff
path: root/games-kids/gmult/gmult-10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /games-kids/gmult/gmult-10.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'games-kids/gmult/gmult-10.0.ebuild')
-rw-r--r--games-kids/gmult/gmult-10.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-kids/gmult/gmult-10.0.ebuild b/games-kids/gmult/gmult-10.0.ebuild
new file mode 100644
index 000000000000..6df28b33de33
--- /dev/null
+++ b/games-kids/gmult/gmult-10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson vala xdg
+
+DESCRIPTION="Multiplication Puzzle emulates the multiplication game found in Emacs"
+HOMEPAGE="https://launchpad.net/gmult/"
+SRC_URI="https://launchpad.net/gmult/trunk/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # only used for unnecessary .desktop/.po validation
+
+RDEPEND="
+ dev-libs/glib:2
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[vala]
+ virtual/libintl
+ x11-libs/cairo
+ x11-libs/pango"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext"
+
+DOCS=( NEWS.md README.md )
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}