summaryrefslogtreecommitdiff
path: root/games-kids/memonix/memonix-1.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
commit7c7c2c9727d6b2ff30945b5aea0d575e1c406d8b (patch)
treebac2a67fb24ac0836147fe370d30e1610ae1845d /games-kids/memonix/memonix-1.6-r1.ebuild
parent2f8db31405fac68eea6f7257d58529243815033b (diff)
gentoo resync : 02.05.2018
Diffstat (limited to 'games-kids/memonix/memonix-1.6-r1.ebuild')
-rw-r--r--games-kids/memonix/memonix-1.6-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-kids/memonix/memonix-1.6-r1.ebuild b/games-kids/memonix/memonix-1.6-r1.ebuild
new file mode 100644
index 000000000000..72187823716e
--- /dev/null
+++ b/games-kids/memonix/memonix-1.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils eutils
+
+DESCRIPTION="Brain teasers, puzzle and memory games for kid's in one pack"
+HOMEPAGE="http://www.viewizard.com/memonix/"
+SRC_URI="http://www.viewizard.com/download/${PN}_${PV}_src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl:0[sound,opengl,video,X]
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-mixer[vorbis]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/MemonixSourceCode"
+
+src_install() {
+ exeinto /usr/"$(get_libdir)"
+ doexe ../${P}_build/Memonix
+
+ insinto "/usr/share/${PN}"
+ doins ../gamedata.vfs
+
+ make_wrapper ${PN} /usr/"$(get_libdir)"/Memonix /usr/share/${PN}
+
+ newicon ../icon48.png ${PN}.png
+ make_desktop_entry ${PN}
+
+ dodoc ReadMe.txt
+}