summaryrefslogtreecommitdiff
path: root/games-kids/pytraffic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-kids/pytraffic
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-kids/pytraffic')
-rw-r--r--games-kids/pytraffic/Manifest4
-rw-r--r--games-kids/pytraffic/files/pytraffic6
-rw-r--r--games-kids/pytraffic/metadata.xml11
-rw-r--r--games-kids/pytraffic/pytraffic-2.5.4-r2.ebuild82
4 files changed, 103 insertions, 0 deletions
diff --git a/games-kids/pytraffic/Manifest b/games-kids/pytraffic/Manifest
new file mode 100644
index 000000000000..5021b399935b
--- /dev/null
+++ b/games-kids/pytraffic/Manifest
@@ -0,0 +1,4 @@
+AUX pytraffic 84 BLAKE2B 5e89b42368a312b59271dd2d97cb26c90507f29d5f447656a8a049d5616a4dd493c93af3ab0bd88b1482f53dbbe27ca0ac6cdcd48c433a4c1871834649f23bfd SHA512 af94d6fc6402e57b78461e65e8eca0ebdd789540a1b8113ed844bfd8bcc4aeff18683c5b254f20b05427d172ac50be06be9d6f8459cf51396a8b8fdd7cb332d9
+DIST pytraffic-2.5.4.tar.gz 2474006 BLAKE2B 4a2570d52aeac340812c7d1f251b6185fc8039ec06e4178d21a5f490b10bc82961fea0423dd3a3a4ec41271037f9a343fcf770d92fe071c4e929159bbbb2373b SHA512 c34a9b783e7de998b8ebc39c2ed2bf1b9a40b090c498773297da455b182aaa5f2047fb541bb11a91e11abdeffee9f02b04a37861135c5fa946fccabfc21b44c1
+EBUILD pytraffic-2.5.4-r2.ebuild 1714 BLAKE2B 1609d09a298a4c5098ab5c43b96d8ac6451b8b1816d58f922e5c8a56794fc543d47244d36728e96afc06fe4b49274b9d876654d24d86f856083c161c6ec9cb78 SHA512 da9a301719b8f9c41acbe4cc8e5a69123330a164a8c2d1ec7d51e948d0152969af8450950ef4954c3d4039785254d6c9026e0c2c7271f22315ead96a75e01ae9
+MISC metadata.xml 329 BLAKE2B 1a6d27d8cbd0cb64761f22fdfec0dde92a2309d8af353b6ee74c6e2c41273ae0a033674ea34019a76d3deb7938908236624520d6c1caaedeefe978d36f679e4c SHA512 9dc7087d6e8f9238e014a01f75ac366608fb881eb8d905412a590c7fe52d931d624a2c07164c861511e27152ca1a7b9e095db30b64cc7733cfd2e7e20abc6c60
diff --git a/games-kids/pytraffic/files/pytraffic b/games-kids/pytraffic/files/pytraffic
new file mode 100644
index 000000000000..30ab25196ce7
--- /dev/null
+++ b/games-kids/pytraffic/files/pytraffic
@@ -0,0 +1,6 @@
+#!/usr/bin/env python
+
+import os
+os.chdir("@GAMES_DATADIR@")
+import pytraffic.Main
+
diff --git a/games-kids/pytraffic/metadata.xml b/games-kids/pytraffic/metadata.xml
new file mode 100644
index 000000000000..9814659ba9cc
--- /dev/null
+++ b/games-kids/pytraffic/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freecode">pytraffic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-kids/pytraffic/pytraffic-2.5.4-r2.ebuild b/games-kids/pytraffic/pytraffic-2.5.4-r2.ebuild
new file mode 100644
index 000000000000..c3d2b8f0a0c8
--- /dev/null
+++ b/games-kids/pytraffic/pytraffic-2.5.4-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2-utils python-utils-r1 python-r1 distutils-r1
+
+DESCRIPTION="Python version of the board game Rush Hour"
+HOMEPAGE="http://freecode.com/projects/pytraffic"
+SRC_URI="http://alpha.uhasselt.be/Research/Algebra/Members/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl:0[sound]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}
+ dev-python/pygtk"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # FHS compliance
+ sed -i \
+ -e 's#return os.path.join(exec_dir,path)#return os.path.join(os.getcwd(),path)#' \
+ Misc.py || die
+
+ sed \
+ -e "s#@GAMES_DATADIR@#/usr/share/${PN}#" \
+ "${FILESDIR}"/${PN} > "${T}"/${PN} || die
+}
+
+python_install() {
+ # install modules manually, build system broken
+ python_moduleinto ${PN}
+ python_domodule "${BUILD_DIR}"/lib/.
+
+ # allow to import the stuff as module
+ touch "${D}$(python_get_sitedir)"/${PN}/__init__.py || die
+
+ # install python wrapper script to handle multiple ABI properly
+ python_scriptinto /usr/bin
+ python_doscript "${T}"/${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/${PN}
+ doins -r doc config.db extra_themes icons libglade music sound_test themes ttraffic.levels
+
+ doicon -s 64 icons/64x64/${PN}.png
+ make_desktop_entry ${PN} PyTraffic
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}