summaryrefslogtreecommitdiff
path: root/games-misc/bsd-games/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /games-misc/bsd-games/files
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'games-misc/bsd-games/files')
-rw-r--r--games-misc/bsd-games/files/bsd-games-3.2-no-strip.patch32
-rw-r--r--games-misc/bsd-games/files/bsd-games-3.2-no-which.patch30
2 files changed, 62 insertions, 0 deletions
diff --git a/games-misc/bsd-games/files/bsd-games-3.2-no-strip.patch b/games-misc/bsd-games/files/bsd-games-3.2-no-strip.patch
new file mode 100644
index 000000000000..1afd6772a8f3
--- /dev/null
+++ b/games-misc/bsd-games/files/bsd-games-3.2-no-strip.patch
@@ -0,0 +1,32 @@
+https://github.com/msharov/bsd-games/commit/b3d60ff0f7aa377594e6b9a2e1d1d8a509501beb
+
+From: Mike Sharov <msharov@users.sourceforge.net>
+Date: Sun, 3 Apr 2022 09:16:27 -0400
+Subject: [PATCH] Remove -s arg to install program
+
+If configure was not called with --with-debug, executables are already
+built stripped. Additional stripping during installation is not needed.
+--- a/Config.mk.in
++++ b/Config.mk.in
+@@ -7,7 +7,7 @@ AR := @AR@
+ RANLIB := @RANLIB@
+ INSTALL := @INSTALL@
+ INSTALL_DATA := ${INSTALL} -m 644
+-INSTALL_PROGRAM := ${INSTALL} -m 755 -s
++INSTALL_PROGRAM := ${INSTALL} -m 755
+ INSTALL_SCORE := ${INSTALL} -m 664 -g users /dev/null
+
+ ################ Destination #########################################
+
+diff --git a/Config.mk.in b/Config.mk.in
+index e069054..d9ee2cb 100644
+--- a/Config.mk.in
++++ b/Config.mk.in
+@@ -30,7 +30,6 @@ ifdef debug
+ ldflags := -g -rdynamic
+ else
+ cflags := -Os -g0 -DNDEBUG=1
+- ldflags := -s
+ endif
+ CFLAGS := -Wall -Wextra -Wstrict-prototypes -Wshadow
+ cflags += -std=c11 @pkg_cflags@ ${CFLAGS}
diff --git a/games-misc/bsd-games/files/bsd-games-3.2-no-which.patch b/games-misc/bsd-games/files/bsd-games-3.2-no-which.patch
new file mode 100644
index 000000000000..c38dda4ef462
--- /dev/null
+++ b/games-misc/bsd-games/files/bsd-games-3.2-no-which.patch
@@ -0,0 +1,30 @@
+https://github.com/msharov/bsd-games/pull/12
+--- a/configure
++++ b/configure
+@@ -145,7 +145,7 @@ s/@builddir@/\$\{TMPDIR\}\/make/g"
+
+ #### Find headers, libs, programs, and subs ##########################
+
+-# Programs found using which
++# Programs found using command -v
+ for i in $progs; do
+ pname=$(expr $i : '\([^=]*\)')
+ pcall=$(expr $i : '[^=]*=\([^=]*\)')
+@@ -153,7 +153,7 @@ for i in $progs; do
+ # First check if an environment variable is set
+ [ -n "$ppath" ] && sub "s/@$pname@/$ppath/g"
+ # Check if the program exists
+- ppath=$(which $pcall 2>/dev/null)
++ ppath=$(command -v $pcall 2>/dev/null)
+ [ -n "$ppath" ] && [ -x "$ppath" ] && sub "s/@$pname@/$pcall/g"
+ done
+ # If nothing found in first loop, set the first pair anyway
+@@ -164,7 +164,7 @@ for i in $progs; do
+ done
+
+ # Packages found using pkg-config
+-pkgconfig=$(which pkg-config 2>/dev/null)
++pkgconfig=$(command -v pkg-config 2>/dev/null)
+ if [ -n "$pkgconfig" ] && [ -x "$pkgconfig" ]; then
+ faildeps=""
+ for i in $pkgs; do