summaryrefslogtreecommitdiff
path: root/games-misc/c++robots/c++robots-0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-misc/c++robots/c++robots-0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-misc/c++robots/c++robots-0-r1.ebuild')
-rw-r--r--games-misc/c++robots/c++robots-0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-misc/c++robots/c++robots-0-r1.ebuild b/games-misc/c++robots/c++robots-0-r1.ebuild
new file mode 100644
index 000000000000..bb398f5ac30a
--- /dev/null
+++ b/games-misc/c++robots/c++robots-0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="ongoing 'King of the Hill' (KotH) tournament"
+HOMEPAGE="http://www.gamerz.net/c++robots/"
+SRC_URI="http://www.gamerz.net/c++robots/c++robots.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}/proper-coding.patch"
+)
+
+src_compile() {
+ local myldflags="${LDFLAGS}"
+ use static && myldflags="${myldflags} -static"
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${myldflags}"
+}
+
+src_install() {
+ dobin combat cylon target tracker
+ dodoc README
+}