summaryrefslogtreecommitdiff
path: root/games-misc/c++robots/c++robots-0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/c++robots/c++robots-0-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/c++robots/c++robots-0-r1.ebuild')
-rw-r--r--games-misc/c++robots/c++robots-0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-misc/c++robots/c++robots-0-r1.ebuild b/games-misc/c++robots/c++robots-0-r1.ebuild
new file mode 100644
index 000000000000..bb398f5ac30a
--- /dev/null
+++ b/games-misc/c++robots/c++robots-0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="ongoing 'King of the Hill' (KotH) tournament"
+HOMEPAGE="http://www.gamerz.net/c++robots/"
+SRC_URI="http://www.gamerz.net/c++robots/c++robots.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}/proper-coding.patch"
+)
+
+src_compile() {
+ local myldflags="${LDFLAGS}"
+ use static && myldflags="${myldflags} -static"
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${myldflags}"
+}
+
+src_install() {
+ dobin combat cylon target tracker
+ dodoc README
+}