summaryrefslogtreecommitdiff
path: root/games-misc/c++robots/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/c++robots/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/c++robots/files')
-rw-r--r--games-misc/c++robots/files/proper-coding.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-misc/c++robots/files/proper-coding.patch b/games-misc/c++robots/files/proper-coding.patch
new file mode 100644
index 000000000000..93b87c1c1da5
--- /dev/null
+++ b/games-misc/c++robots/files/proper-coding.patch
@@ -0,0 +1,51 @@
+--- c++robots.orig/Makefile
++++ c++robots/Makefile
+@@ -1,38 +1,37 @@
+ CFLAGS=-g
++LDFLAGS=
+ PROGRAMS=combat
+ ROBOTS=cylon tracker target
+
+-CC=g++ -g
+-
+ all: $(PROGRAMS) $(ROBOTS)
+
+ clean:
+ rm -f $(PROGRAMS) $(ROBOTS) *.o core
+
+ combat: combat.o
+- $(CC) $(CFLAGS) -o $@ combat.o -lm
++ $(CXX) -o $@ $(LDFLAGS) combat.o -lm
+
+ combat.o: combat.c
+- $(CC) $(CFLAGS) -c combat.c
++ $(CXX) $(CXXFLAGS) -c combat.c
+
+ robots.o: robots.C robots.h
+- g++ -c robots.C
++ $(CXX) $(CXXFLAGS) -c robots.C
+
+ cylon: cylon.o robots.o
+- g++ -static -o $@ cylon.o robots.o
++ $(CXX) -o $@ $(LDFLAGS) cylon.o robots.o
+
+ cylon.o: cylon.c robots.h
+- g++ -c cylon.c
++ $(CXX) $(CXXFLAGS) -c cylon.c
+
+ tracker: tracker.o robots.o
+- g++ -static -o $@ tracker.o robots.o
++ $(CXX) -o $@ $(LDFLAGS) tracker.o robots.o
+
+ tracker.o: tracker.c robots.h
+- g++ -c tracker.c
++ $(CXX) $(CXXFLAGS) -c tracker.c
+
+ target: target.o robots.o
+- g++ -static -o $@ target.o robots.o
++ $(CXX) -o $@ $(LDFLAGS) target.o robots.o
+
+ target.o: target.c robots.h
+- g++ -c target.c
++ $(CXX) $(CXXFLAGS) -c target.c
+