summaryrefslogtreecommitdiff
path: root/games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10-r1.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10-r1.ebuild')
-rw-r--r--games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10-r1.ebuild b/games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10-r1.ebuild
new file mode 100644
index 000000000000..fe29cde2fa13
--- /dev/null
+++ b/games-misc/fortune-mod-flashrider/fortune-mod-flashrider-1.10-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-mod/s}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Quotes from Prolinux articles and comments"
+HOMEPAGE="https://github.com/Nanolx/fortunes-flashrider"
+SRC_URI="https://github.com/Nanolx/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+RDEPEND="games-misc/fortune-mod"
+
+src_prepare()
+{
+ sed -e 's#INSTALLDIR = .*#INSTALLDIR = /share/fortune#' -i Makefile
+ eapply_user
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}"/usr DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog README
+}