summaryrefslogtreecommitdiff
path: root/games-misc/funny-manpages/funny-manpages-2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/funny-manpages/funny-manpages-2.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/funny-manpages/funny-manpages-2.3.ebuild')
-rw-r--r--games-misc/funny-manpages/funny-manpages-2.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-misc/funny-manpages/funny-manpages-2.3.ebuild b/games-misc/funny-manpages/funny-manpages-2.3.ebuild
new file mode 100644
index 000000000000..2ab4b79b95e9
--- /dev/null
+++ b/games-misc/funny-manpages/funny-manpages-2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_R="${PV:0-1}"
+MY_P="${PN}_${PV/_p?/}"
+DESCRIPTION="funny manpages collected from various sources"
+HOMEPAGE="https://www.debian.org/"
+SRC_URI="mirror://debian/pool/main/f/funny-manpages/${MY_P}.orig.tar.gz"
+
+if [[ "${PV}" = *_p* ]] ; then
+ SRC_URI+=" mirror://debian/pool/main/f/funny-manpages/${MY_P}-${MY_R}.diff.gz"
+fi
+
+LICENSE="freedist" #465704
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~m68k ~mips ~ppc64 ~s390 ~sh ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+
+S="${WORKDIR}/${PN}/man"
+
+src_prepare() {
+ if [[ "${PV}" = *_p* ]] ; then
+ eapply "${WORKDIR}"/${MY_P}-${MY_R}.diff
+ fi
+
+ eapply_user
+
+ for f in *.[0-57-9]fun ; do
+ mv ${f} ${f/.?fun/.6fun} || die "renaming ${f} failed"
+ done
+}
+
+src_install() {
+ doman *.6fun
+}