summaryrefslogtreecommitdiff
path: root/games-misc/papers-please
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/papers-please
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/papers-please')
-rw-r--r--games-misc/papers-please/Manifest3
-rw-r--r--games-misc/papers-please/metadata.xml8
-rw-r--r--games-misc/papers-please/papers-please-1.1.65.ebuild70
3 files changed, 81 insertions, 0 deletions
diff --git a/games-misc/papers-please/Manifest b/games-misc/papers-please/Manifest
new file mode 100644
index 000000000000..791f22a1af9d
--- /dev/null
+++ b/games-misc/papers-please/Manifest
@@ -0,0 +1,3 @@
+DIST papers-please_1.1.65_i386.tar.gz 31566799 BLAKE2B 1e7aee7839f5e014d5eba60b5c77381a79c7532610e6daee1a36b22484a59b07e8e6b7bce3fc28720472268b78857894744ef6750dcee37e637003b2bc14a502 SHA512 093990a61c1b61d2999e6484335f4deddfecd3d66b7a5e29555c3170e890f6049f7d42a83529dcd993439de940b5dc96b8485d30ab46995d0f6814d5282669e0
+EBUILD papers-please-1.1.65.ebuild 1413 BLAKE2B 7ffd79b71c896447068677c3a4b63c905bc9465c6e1770ce0f5e81c4ffb8a6731d7056c8e2f7a79d02270af8bd77c391cb1fc496bb5654c793425fbbe0a78bb9 SHA512 a400988a8d1c9b65d8f46ac57c38eca4c96f6ed61147af53427352111a5be2748f72c3911fd2b294b12c5ac6af9ac940cb89af126107ed8ec5f9b8395238af01
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-misc/papers-please/metadata.xml b/games-misc/papers-please/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-misc/papers-please/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-misc/papers-please/papers-please-1.1.65.ebuild b/games-misc/papers-please/papers-please-1.1.65.ebuild
new file mode 100644
index 000000000000..fc553bd4d136
--- /dev/null
+++ b/games-misc/papers-please/papers-please-1.1.65.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="A Dystopian Document Thriller"
+HOMEPAGE="http://papersplea.se"
+SRC_URI="papers-please_${PV}_i386.tar.gz"
+
+LICENSE="PAPERS-PLEASE"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch bindist"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/*"
+
+RDEPEND="
+ amd64? (
+ >=x11-libs/libX11-1.6.2[abi_x86_32]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32]
+ >=x11-libs/libXext-1.3.2[abi_x86_32]
+ >=x11-libs/libXxf86vm-1.1.3[abi_x86_32]
+ >=x11-libs/libdrm-2.4.46[abi_x86_32]
+ >=x11-libs/libxcb-1.9.1[abi_x86_32]
+ >=virtual/opengl-7.0-r1[abi_x86_32]
+ )
+ x86? (
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ x11-libs/libdrm
+ x11-libs/libxcb
+ virtual/opengl
+ )"
+
+S=${WORKDIR}/${PN}
+
+pkg_nofetch() {
+ einfo
+ einfo "Please buy & download \"${SRC_URI}\" from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo
+}
+
+src_prepare() {
+ rm -v launch.sh LICENSE || die
+ mv README "${T}"/README || die
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r *
+ fperms +x "${dir}"/PapersPlease
+
+ games_make_wrapper ${PN} "./PapersPlease" "${dir}" "${dir}"
+ make_desktop_entry ${PN} "Papers, Please"
+
+ dodoc "${T}"/README
+
+ prepgamesdirs
+}