summaryrefslogtreecommitdiff
path: root/games-misc/ponysay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-misc/ponysay
reinit the tree, so we can have metadata
Diffstat (limited to 'games-misc/ponysay')
-rw-r--r--games-misc/ponysay/Manifest4
-rw-r--r--games-misc/ponysay/metadata.xml15
-rw-r--r--games-misc/ponysay/ponysay-3.0.2.ebuild60
3 files changed, 79 insertions, 0 deletions
diff --git a/games-misc/ponysay/Manifest b/games-misc/ponysay/Manifest
new file mode 100644
index 000000000000..d07d475a35c4
--- /dev/null
+++ b/games-misc/ponysay/Manifest
@@ -0,0 +1,4 @@
+DIST ponysay-3.0.2.tar.gz 2110382 SHA256 69e98a7966353de2f232cbdaccd8ef7dbc5d0bcede9bf7280a676793e8625b0d SHA512 47d5c584b3b8c233567eff534b5109548c92075f69776703bc303929ba4278f67fd599987ef4a098aa871c2af0efd89186f96fa28565e73b4672abeb0c23fa45 WHIRLPOOL 9ba79521c95948498cffb3fa8c921dfeab9188d215ddd57c777517e54453979ea4f40ec1faea894a8a967fce78fe08767bf915d7bdeca4807a337099e7d8c265
+EBUILD ponysay-3.0.2.ebuild 1457 SHA256 02c8c9ae43ce50d4e771fa2bc27ac251851224990d1e94ca5781b2abfa90fff5 SHA512 d588685120d7ce8b8f5bb68ecd082c057767b9e87a2dc05faba78772a43f487c1e901b3cf5a92d95c362a34eef7522c426301745bb0fabd91feefb383b94aa0a WHIRLPOOL d1920dcdcb169a2134ddce78141c7696a556ac0999fde9689859569fb59e58de6dd6b28d39330353e2271169b555d6b458fd6e073e51e3b74f5d23fb44081448
+MISC ChangeLog 427 SHA256 87c6ea4bb3f64287dbf6a481bab3694e0b7adca094b8bf2b9a64a3fe7b598328 SHA512 e8d8e913163e2fc09d0ef135bbf8c8b1f09b236dd6413154161d2c214955695109982d9bf025851eaa0913c13a40132c36a2902483282225949bc032ed8ef1be WHIRLPOOL 78d4d1657d4fa1bedc20736d337a2b3c902ebdee88af1348fa32285ee7442caef012e25095cbb94b304126b5f5097268b4f7c09d1b71262e2cd8a9845da7dee0
+MISC metadata.xml 500 SHA256 a94427dcb5b6eb0ca10273019c5b5f6832d43e40def305e6aeec6a5c99c77890 SHA512 612eee4d25e1f3e3ef18b08ac4fcf59fbee5ab179d1f4da5e6784909c1985aa816317eba1a4c1a0aae8b1dfc0bfcc63ea44ab844b1400e565a2ebfaf5d7f8d4c WHIRLPOOL be41603386fc3ed0cfc5ea285564c9c727f276ea0f0ca78226224945f3f56ace4e27fb67b536cb9c8b7f0d27fcab32b2c4d972f4269b3abca3830fcea259180f
diff --git a/games-misc/ponysay/metadata.xml b/games-misc/ponysay/metadata.xml
new file mode 100644
index 000000000000..288c0bcfb305
--- /dev/null
+++ b/games-misc/ponysay/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="fish-completion">Enable fish completion support</flag>
+ <flag name="non-free">Install non-free ponies (i.e. from the MLP franchise)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">erkin/ponysay</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-misc/ponysay/ponysay-3.0.2.ebuild b/games-misc/ponysay/ponysay-3.0.2.ebuild
new file mode 100644
index 000000000000..ae7e8c164e17
--- /dev/null
+++ b/games-misc/ponysay/ponysay-3.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+inherit bash-completion-r1 python-single-r1
+
+DESCRIPTION="cowsay reimplemention for ponies"
+HOMEPAGE="https://github.com/erkin/ponysay"
+SRC_URI="https://github.com/erkin/ponysay/archive/3.0.2.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +non-free bash-completion fish-completion zsh-completion"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ doc? ( sys-apps/texinfo )"
+
+RDEPEND="${PYTHON_DEPS}
+ fish-completion? ( app-shells/fish )
+ zsh-completion? ( app-shells/zsh )"
+
+setup_py() {
+ "${PYTHON}" setup.py \
+ --prefix="${EPREFIX}"/usr \
+ --everything \
+ --without-info-compression \
+ --without-man-compression \
+ --without-pdf-compression \
+ --without-shared-cache \
+ --freedom=$(usex non-free no yes) \
+ $(use_with fish-completion) \
+ $(use_with zsh-completion) \
+ $(use_with doc info) \
+ $(use_with doc pdf "${EPREFIX}"/usr/share/doc/${PF}) \
+ "${@}" || die
+}
+
+src_compile() {
+ setup_py \
+ $(use_with bash-completion) \
+ build
+}
+
+src_install() {
+ setup_py \
+ --without-bash-completion \
+ --destdir="${D}" \
+ prebuilt
+
+ python_fix_shebang "${ED}"/usr/bin/${PN}
+
+ rm -rv "${ED}"/usr/share/licenses || die
+ dodoc CHANGELOG CONTRIBUTING CREDITS README.md
+
+ use bash-completion &&
+ newbashcomp completion/bash-completion.${PN}.install ${PN}
+}