summaryrefslogtreecommitdiff
path: root/games-puzzle/amoebax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/amoebax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/amoebax')
-rw-r--r--games-puzzle/amoebax/Manifest5
-rw-r--r--games-puzzle/amoebax/amoebax-0.2.1-r1.ebuild40
-rw-r--r--games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch41
-rw-r--r--games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch12
-rw-r--r--games-puzzle/amoebax/metadata.xml8
5 files changed, 106 insertions, 0 deletions
diff --git a/games-puzzle/amoebax/Manifest b/games-puzzle/amoebax/Manifest
new file mode 100644
index 000000000000..88c3507409a8
--- /dev/null
+++ b/games-puzzle/amoebax/Manifest
@@ -0,0 +1,5 @@
+AUX amoebax-0.2.1-aclocal.patch 1536 BLAKE2B bb83bfc7e254ca1f649a735121ba8f9bc71abe35c7c935083d50682ee7cbd77b6eeb5f87ac35b5235f46d5abf8b0a995796548401ed2b943b3acf374bd6e18d9 SHA512 f5f501b0bbe76902c65d404e7aebf830d84c329cf8d84ee5c769660bb4a30cbfbae9a0e16eb2697bd693de77ef38811ac52e68fe799add00b97292c2e79a2d27
+AUX amoebax-0.2.1-compile.patch 227 BLAKE2B de56259f5d58fd3509b2fe2b6d51e7ecd3bdebee4196d03ca3529a24e10123f005529b6e0e9fb434a45c7a8caaaf8197ce9e730276bd3631ad5e3c1b47df2ffc SHA512 fe6b2b3b7d61f5548fc9959dce491e25cdf51313bc46141615e3ea5e96edff34084ac8294b0b8ddace6dc6a374a02cd173e3a4308cb9d56018535f62dfa6defe
+DIST amoebax-0.2.1.tar.bz2 10645579 BLAKE2B 0e8f5d5bb92dd20444bfcb735fdc28142bc359676e057471089b94a6df8a8b45cdecdb1462022909f025310fbc9da1946a50a4d716aa75e34ffc71b4fbc8cfbe SHA512 f8cd20cb35e2456487f55ebc89411ebd47b25cf549d35c36041a27e1d96ef30702151f303dbb457afbf8583f67c53143c30becdea00a26fddad20555e0c7d181
+EBUILD amoebax-0.2.1-r1.ebuild 937 BLAKE2B 796983bbdbe49edcb964bc15095e2a049599ec0f523223277f124c42d3310369d176738ec99ab0834a063585b4e34134aed72cd005d96ab4b7da06a43fe27bdb SHA512 5f7de2cdf5fe0f91b32f012f61f8d3cd8a589e88dcf70d44b4139372e6e0df4541188c71e4bb3c1d4ec90fd1ee427ac91129802514587c9f95e7533c9c7c9ea3
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/amoebax/amoebax-0.2.1-r1.ebuild b/games-puzzle/amoebax/amoebax-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..316d438bcddd
--- /dev/null
+++ b/games-puzzle/amoebax/amoebax-0.2.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A cute and addictive action-puzzle game, similar to tetris"
+HOMEPAGE="http://www.emma-soft.com/games/amoebax/"
+SRC_URI="http://www.emma-soft.com/games/amoebax/download/${P}.tar.bz2"
+
+LICENSE="FreeArt GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ default
+
+ eapply \
+ "${FILESDIR}"/${P}-aclocal.patch \
+ "${FILESDIR}"/${P}-compile.patch
+
+ sed -i \
+ -e "/^SUBDIRS/s:doc ::" \
+ Makefile.am || die
+ sed -i \
+ -e "/^iconsdir/s:=.*:=/usr/share/pixmaps:" \
+ -e "/^desktopdir/s:=.*:=/usr/share/applications:" \
+ data/Makefile.am || die
+ sed -i \
+ -e '/Encoding/d' \
+ -e '/Icon/s/.svg//' \
+ data/amoebax.desktop || die
+ AT_M4DIR=m4 eautoreconf
+}
diff --git a/games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch b/games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch
new file mode 100644
index 000000000000..11d903516c19
--- /dev/null
+++ b/games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch
@@ -0,0 +1,41 @@
+--- a/m4/objc.m4.old
++++ b/m4/objc.m4
+@@ -448,32 +448,32 @@
+
+ # AC_LANG_SOURCE(Objective C)(BODY)
+ # ---------------------------------
+-m4_copy([AC_LANG_SOURCE(C)], [AC_LANG_SOURCE(Objective C)])
++m4_copy_force([AC_LANG_SOURCE(C)], [AC_LANG_SOURCE(Objective C)])
+
+
+ # AC_LANG_PROGRAM(Objective C)([PROLOGUE], [BODY])
+ # ------------------------------------------------
+-m4_copy([AC_LANG_PROGRAM(C)], [AC_LANG_PROGRAM(Objective C)])
++m4_copy_force([AC_LANG_PROGRAM(C)], [AC_LANG_PROGRAM(Objective C)])
+
+
+ # AC_LANG_CALL(Objective C)(PROLOGUE, FUNCTION)
+ # ---------------------------------------------
+-m4_copy([AC_LANG_CALL(C)], [AC_LANG_CALL(Objective C)])
++m4_copy_force([AC_LANG_CALL(C)], [AC_LANG_CALL(Objective C)])
+
+
+ # AC_LANG_FUNC_LINK_TRY(Objective C)(FUNCTION)
+ # --------------------------------------------
+-m4_copy([AC_LANG_FUNC_LINK_TRY(C)], [AC_LANG_FUNC_LINK_TRY(Objective C)])
++m4_copy_force([AC_LANG_FUNC_LINK_TRY(C)], [AC_LANG_FUNC_LINK_TRY(Objective C)])
+
+
+ # AC_LANG_BOOL_COMPILE_TRY(Objective C)(PROLOGUE, EXPRESSION)
+ # -----------------------------------------------------------
+-m4_copy([AC_LANG_BOOL_COMPILE_TRY(C)], [AC_LANG_BOOL_COMPILE_TRY(Objective C)])
++m4_copy_force([AC_LANG_BOOL_COMPILE_TRY(C)], [AC_LANG_BOOL_COMPILE_TRY(Objective C)])
+
+
+ # AC_LANG_INT_SAVE(Objective C)(PROLOGUE, EXPRESSION)
+ # ---------------------------------------------------
+-m4_copy([AC_LANG_INT_SAVE(C)], [AC_LANG_INT_SAVE(Objective C)])
++m4_copy_force([AC_LANG_INT_SAVE(C)], [AC_LANG_INT_SAVE(Objective C)])
+
+
+
diff --git a/games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch b/games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch
new file mode 100644
index 000000000000..6be301674149
--- /dev/null
+++ b/games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch
@@ -0,0 +1,12 @@
+--- a/src/binreloc.cxx
++++ b/src/binreloc.cxx
+@@ -739,7 +739,8 @@
+ char *
+ br_dirname (const char *path)
+ {
+- char *end, *result;
++ const char *end;
++ char *result;
+
+ if (path == (const char *) NULL)
+ return (char *) NULL;
diff --git a/games-puzzle/amoebax/metadata.xml b/games-puzzle/amoebax/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/amoebax/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>