summaryrefslogtreecommitdiff
path: root/games-puzzle/arrows/arrows-0.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /games-puzzle/arrows/arrows-0.6-r1.ebuild
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'games-puzzle/arrows/arrows-0.6-r1.ebuild')
-rw-r--r--games-puzzle/arrows/arrows-0.6-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-puzzle/arrows/arrows-0.6-r1.ebuild b/games-puzzle/arrows/arrows-0.6-r1.ebuild
new file mode 100644
index 000000000000..5e3b5c6834b5
--- /dev/null
+++ b/games-puzzle/arrows/arrows-0.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Simple maze-like game where you navigate around and destroy arrows"
+HOMEPAGE="http://noreason.ca/?file=software"
+SRC_URI="http://noreason.ca/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Modify path to data
+ sed -i \
+ -e "s:arrfl:/usr/share/${PN}/arrfl:" \
+ -e 's:nm\[9:nm[35:' \
+ -e 's:nm\[6:nm[30:' \
+ -e 's:nm\[7:nm[31:' \
+ game.c \
+ || die 'sed failed'
+ sed -i \
+ -e '/^CC /d' \
+ -e '/CCLIBS/s:$: $(LDFLAGS):' \
+ Makefile \
+ || die 'sed failed'
+}
+
+src_compile() {
+ make clean || die "make clean failed"
+ emake CCOPTS="${CFLAGS}"
+}
+
+src_install() {
+ dobin arrows
+ insinto "/usr/share/${PN}"
+ doins arrfl*
+ einstalldocs
+}