summaryrefslogtreecommitdiff
path: root/games-puzzle/braid-hb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /games-puzzle/braid-hb
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'games-puzzle/braid-hb')
-rw-r--r--games-puzzle/braid-hb/Manifest3
-rw-r--r--games-puzzle/braid-hb/braid-hb-20150611.ebuild55
-rw-r--r--games-puzzle/braid-hb/metadata.xml8
3 files changed, 66 insertions, 0 deletions
diff --git a/games-puzzle/braid-hb/Manifest b/games-puzzle/braid-hb/Manifest
new file mode 100644
index 000000000000..93af217638c3
--- /dev/null
+++ b/games-puzzle/braid-hb/Manifest
@@ -0,0 +1,3 @@
+DIST BraidSetup-2015-06-11.sh 121622129 BLAKE2B 9cb255621c6e2461dff0ca0dc779d62aef09a16d413e1909c505e41be1db5475be5ced8e16ce8d989faa70f3f7a614e3ac7af99a28feccf1859182dca762b042 SHA512 8f27efd0e6514f92c177663d5cb342b026017e66abe2a46df6b08880a28c8220a7cfcb5607eaf01ace3a39c7c8af5e5f9f62c661d4018cdadc102f4caf677a93
+EBUILD braid-hb-20150611.ebuild 1253 BLAKE2B 86c4202b66b8dcf8ab49e92dc6f6ce6900a8b0c17c2e2befe8d83d1628bc8a1a39441524119f7ccdd2b535993b73941d3c4621e86b29afae46518675420125c2 SHA512 7194d7f9c23bdbce0dffab101ec06008d04561fc76f51043f7b8fe6f8fc8a612de9a68129eb0d41cd3310a52498bbb36fbdfab8d026252e61882e4479017a9fd
+MISC metadata.xml 254 BLAKE2B 4e6c8e1f126f76233a38aba6f5388488656795cb1d7d4767ccb1349772f5e78d59fc5663d4f1933dbe4633c2fbb90cd1d42d4b4d4f5ededc53653e7df13c7187 SHA512 2b82da849e3b0dec378f3fb497014f5d1dbc7aceb8a1f9d1638e83fe69448b1c5151eb4b1187154d828e4a296609ce5125b40977b2581d95b5588e353ca75135
diff --git a/games-puzzle/braid-hb/braid-hb-20150611.ebuild b/games-puzzle/braid-hb/braid-hb-20150611.ebuild
new file mode 100644
index 000000000000..e289db38e3e0
--- /dev/null
+++ b/games-puzzle/braid-hb/braid-hb-20150611.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker wrapper xdg
+
+MY_PN="braid"
+DESCRIPTION="Platform game where you manipulate flow of time"
+HOMEPAGE="https://www.humblebundle.com/store/braid"
+SRC_URI="BraidSetup-${PV:0:4}-${PV:4:2}-${PV:6:2}.sh"
+
+LICENSE="all-rights-reserved Arphic CC-BY-NC-SA-1.0"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+RDEPEND="
+ media-gfx/nvidia-cg-toolkit[abi_x86_32]
+ media-libs/libsdl2[joystick,opengl,sound,video,abi_x86_32]
+ virtual/opengl[abi_x86_32]
+ x11-libs/fltk:1[abi_x86_32]
+ x11-libs/libX11[abi_x86_32]
+ !${CATEGORY}/${MY_PN}-gog
+"
+
+S="${WORKDIR}/data"
+DIR="/opt/${MY_PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ insinto "${DIR}"
+
+ doexe x86/{Braid,launcher}.bin.x86
+ doins -r noarch/{data,Icon.*}
+ dodoc noarch/READ_ME.txt
+
+ make_wrapper ${MY_PN} ./launcher.bin.x86 "${DIR}" /usr/$(ABI=x86 get_libdir)/fltk
+ make_desktop_entry ${MY_PN} Braid "${EPREFIX}${DIR}"/Icon.png
+}
diff --git a/games-puzzle/braid-hb/metadata.xml b/games-puzzle/braid-hb/metadata.xml
new file mode 100644
index 000000000000..7c730d47817a
--- /dev/null
+++ b/games-puzzle/braid-hb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>