summaryrefslogtreecommitdiff
path: root/games-puzzle/cuyo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-puzzle/cuyo/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-puzzle/cuyo/files')
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch11
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gcc6.patch45
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch30
3 files changed, 86 insertions, 0 deletions
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch
new file mode 100644
index 000000000000..9ad50b067fb5
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch
@@ -0,0 +1,11 @@
+--- cuyo-2.~-1.1.orig/src/stringzeug.h
++++ cuyo-2.~-1.1/src/stringzeug.h
+@@ -20,7 +20,7 @@
+
+ #include <config.h>
+ #include <string>
+-
++#include <stdio.h>
+
+
+
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gcc6.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc6.patch
new file mode 100644
index 000000000000..b1ba5b535de5
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc6.patch
@@ -0,0 +1,45 @@
+--- a/src/pfaditerator.h
++++ b/src/pfaditerator.h
+@@ -21,6 +21,11 @@
+ #include "stringzeug.h"
+
+
++#if __cplusplus >= 201103L
++#define NOEXCEPT noexcept(false)
++#else
++#define NOEXCEPT
++#endif
+
+
+ /** Iteriert durch alle Pfade, an denen sich eine
+@@ -43,7 +48,7 @@
+ class PfadIterator {
+ public:
+ PfadIterator(Str dat, bool auch_gz = false, bool setzDefault = false);
+- ~PfadIterator();
++ ~PfadIterator() NOEXCEPT;
+
+ /** N�chster Pfad */
+ PfadIterator & operator++();
+--- a/src/pfaditerator.cpp
++++ b/src/pfaditerator.cpp
+@@ -48,7 +48,7 @@
+ -1 und f�hren dann gleich ein ++ aus. */
+ ++(*this);
+ }
+-PfadIterator::~PfadIterator() {
++PfadIterator::~PfadIterator() NOEXCEPT {
+ /** Soll der default-Pfad gesetzt werden? */
+ if (mSetzDefault) {
+
+--- a/src/xpmladen.cpp
++++ b/src/xpmladen.cpp
+@@ -314,7 +314,7 @@
+ try {
+
+ /* Datei laden. Dabei werden gDatAnfang und gDatEnde gesetzt. */
+- if (!ladeDatei(na)) return false;
++ if (!ladeDatei(na)) return NULL;
+
+
+ gDatBei = gDatAnfang;
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch
new file mode 100644
index 000000000000..78bafe2ded47
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch
@@ -0,0 +1,30 @@
+--- cuyo-2.~-1.1.orig/icons/Makefile.am
++++ cuyo-2.~-1.1/icons/Makefile.am
+@@ -1,4 +1,4 @@
+-desktopdir = $(datadir)/applications
++desktopdir = /usr/share/applications
+ desktop_DATA = cuyo.desktop
+
+
+@@ -25,7 +25,7 @@
+ # Das vorige war falsch: die png sollen alle cuyo.png heissen
+ # und nicht cuyo-xxxx.png. Deshalb nachfolgend neue Version:
+
+-iconsdir = $(datadir)/icons/hicolor
++iconsdir = /usr/share/icons/hicolor
+ icons_DATA = cuyo-32x32.png cuyo-64x64.png
+
+ install-iconsDATA:
+--- cuyo-2.~-1.1.orig/icons/cuyo.desktop
++++ cuyo-2.~-1.1/icons/cuyo.desktop
+@@ -3,9 +3,8 @@
+ Icon=cuyo
+ Type=Application
+ Terminal=false
+-MimeType=application/x-executable
++MimeType=application/x-executable;
+ Categories=Game;BlocksGame;
+-Encoding=UTF-8
+ Comment=A tetris like game with many levels
+ Comment[de]=Ein Tetris-artiges Spiel mit vielen Leveln
+ Exec=cuyo