summaryrefslogtreecommitdiff
path: root/games-puzzle/cuyo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/cuyo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/cuyo')
-rw-r--r--games-puzzle/cuyo/Manifest6
-rw-r--r--games-puzzle/cuyo/cuyo-2.1.1-r1.ebuild46
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch11
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gcc6.patch45
-rw-r--r--games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch30
-rw-r--r--games-puzzle/cuyo/metadata.xml11
6 files changed, 149 insertions, 0 deletions
diff --git a/games-puzzle/cuyo/Manifest b/games-puzzle/cuyo/Manifest
new file mode 100644
index 000000000000..789809a6823c
--- /dev/null
+++ b/games-puzzle/cuyo/Manifest
@@ -0,0 +1,6 @@
+AUX cuyo-2.1.1-gcc44.patch 161 BLAKE2B f6b288dfdf81ac39d0c58e144e36ed554bbec67c5533eb57ae9458fc73f0ca2348b3a3d65170a9c62ff5c8734b61b8e90d631a3044b171981feb27c42a04fc90 SHA512 461bd27073288eb5327770d18ce5a10a38a4e6ceb3c6f5e39a50a47bc3f6f5c8a06f9ac13d80bfbbeae1a0f45dd62ee0fa084dd832eb2d1313096f3d8e5c3149
+AUX cuyo-2.1.1-gcc6.patch 1024 BLAKE2B 12331f090b146d9f26b1a1300830153a599354c302cbe6d400eb3b39b403071853fcdc0a9559da23a0167d863794499e97f9a1f409333b722d9b95cfa9492e3c SHA512 ae8733da8afceee4e54ac8cac5a11d20a1adce494d76cdfaa821ffeba64886d9b0c9680fdab013c67e641bac9c96ba3dc23d1ecb86d1b59ca3f354692d218d2c
+AUX cuyo-2.1.1-gentoo.patch 851 BLAKE2B 70c082a9e19ca1a093810c810825986390abe5a0b0c671eb97dd95e731ee529a9aea1491f3c59651648ad0e9c451ecb269a66d0b17b4f0b237b961e47117e9a7 SHA512 c96c855c4650f50d6ed1c38d7105047f386c1828592389ce482cecefeb46bae224ee46f6f07dc63bbed67d81e4beadd5868962ad52dcca8fd9f99f3ea0899f8a
+DIST cuyo-2.~-1.1.tar.gz 3005426 BLAKE2B af83365568b16d230b8f253589c0300e1ba29471c8a406bd161da20b8282da4ca845aa1a06b8c5b2bf076828a71e0add9c317b710c476f56540a29f87dc53194 SHA512 a29c6ffc7e63b74dd93e8aeeace78bdbc50398771922aaf06a43256c883f9eff23e10fa91e4964b716cd209551cef771cf00108fb7977ce13a463da542322787
+EBUILD cuyo-2.1.1-r1.ebuild 941 BLAKE2B 37b6a8a120d67ec0fa16474ec79a42f320493d9e14b540eeccd3601f80bc3844f73ea44cb3e17b27cc7a909df24b2915cc261378f2a3d78486f4f7bb6f851f16 SHA512 e779d2b956903e8f587b52f5268bd264bbfbbc39a7c60340e2a968a2507059c63292afd6d3e0d96e90c1a88bf2f43492334b3f005c79e94ac595cf1873d87a60
+MISC metadata.xml 324 BLAKE2B 2d20b6235b6445d30b7da2729b4e3367456ebd9ea2b4ce290044e1202714ed0b460151e02af09648fe23e8095ee8aacac77923d232be8d8e0656f35e6f54387b SHA512 3392ab16d9e90d0dd6dba06994ba2096940075961de7e6fed43d70946e82916af7b40e95bd27e25d5eba9d9eb46afe61fe4200147385cc93211ab14c0e6b13ce
diff --git a/games-puzzle/cuyo/cuyo-2.1.1-r1.ebuild b/games-puzzle/cuyo/cuyo-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..55b13cc7ed85
--- /dev/null
+++ b/games-puzzle/cuyo/cuyo-2.1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools gnome2-utils versionator
+
+MY_P="${PN}-$(get_version_component_range 1).~-$(get_version_component_range 2-3)"
+DESCRIPTION="highly addictive and remotely related to tetris"
+HOMEPAGE="http://www.karimmi.de/cuyo/"
+SRC_URI="https://savannah.nongnu.org/download/cuyo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+music"
+
+DEPEND="sys-libs/zlib
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer
+ music? ( media-libs/sdl-mixer[mod] )
+ media-libs/sdl-image
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc6.patch
+ eautoreconf
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch
new file mode 100644
index 000000000000..9ad50b067fb5
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc44.patch
@@ -0,0 +1,11 @@
+--- cuyo-2.~-1.1.orig/src/stringzeug.h
++++ cuyo-2.~-1.1/src/stringzeug.h
+@@ -20,7 +20,7 @@
+
+ #include <config.h>
+ #include <string>
+-
++#include <stdio.h>
+
+
+
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gcc6.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc6.patch
new file mode 100644
index 000000000000..b1ba5b535de5
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-2.1.1-gcc6.patch
@@ -0,0 +1,45 @@
+--- a/src/pfaditerator.h
++++ b/src/pfaditerator.h
+@@ -21,6 +21,11 @@
+ #include "stringzeug.h"
+
+
++#if __cplusplus >= 201103L
++#define NOEXCEPT noexcept(false)
++#else
++#define NOEXCEPT
++#endif
+
+
+ /** Iteriert durch alle Pfade, an denen sich eine
+@@ -43,7 +48,7 @@
+ class PfadIterator {
+ public:
+ PfadIterator(Str dat, bool auch_gz = false, bool setzDefault = false);
+- ~PfadIterator();
++ ~PfadIterator() NOEXCEPT;
+
+ /** N�chster Pfad */
+ PfadIterator & operator++();
+--- a/src/pfaditerator.cpp
++++ b/src/pfaditerator.cpp
+@@ -48,7 +48,7 @@
+ -1 und f�hren dann gleich ein ++ aus. */
+ ++(*this);
+ }
+-PfadIterator::~PfadIterator() {
++PfadIterator::~PfadIterator() NOEXCEPT {
+ /** Soll der default-Pfad gesetzt werden? */
+ if (mSetzDefault) {
+
+--- a/src/xpmladen.cpp
++++ b/src/xpmladen.cpp
+@@ -314,7 +314,7 @@
+ try {
+
+ /* Datei laden. Dabei werden gDatAnfang und gDatEnde gesetzt. */
+- if (!ladeDatei(na)) return false;
++ if (!ladeDatei(na)) return NULL;
+
+
+ gDatBei = gDatAnfang;
diff --git a/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch b/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch
new file mode 100644
index 000000000000..78bafe2ded47
--- /dev/null
+++ b/games-puzzle/cuyo/files/cuyo-2.1.1-gentoo.patch
@@ -0,0 +1,30 @@
+--- cuyo-2.~-1.1.orig/icons/Makefile.am
++++ cuyo-2.~-1.1/icons/Makefile.am
+@@ -1,4 +1,4 @@
+-desktopdir = $(datadir)/applications
++desktopdir = /usr/share/applications
+ desktop_DATA = cuyo.desktop
+
+
+@@ -25,7 +25,7 @@
+ # Das vorige war falsch: die png sollen alle cuyo.png heissen
+ # und nicht cuyo-xxxx.png. Deshalb nachfolgend neue Version:
+
+-iconsdir = $(datadir)/icons/hicolor
++iconsdir = /usr/share/icons/hicolor
+ icons_DATA = cuyo-32x32.png cuyo-64x64.png
+
+ install-iconsDATA:
+--- cuyo-2.~-1.1.orig/icons/cuyo.desktop
++++ cuyo-2.~-1.1/icons/cuyo.desktop
+@@ -3,9 +3,8 @@
+ Icon=cuyo
+ Type=Application
+ Terminal=false
+-MimeType=application/x-executable
++MimeType=application/x-executable;
+ Categories=Game;BlocksGame;
+-Encoding=UTF-8
+ Comment=A tetris like game with many levels
+ Comment[de]=Ein Tetris-artiges Spiel mit vielen Leveln
+ Exec=cuyo
diff --git a/games-puzzle/cuyo/metadata.xml b/games-puzzle/cuyo/metadata.xml
new file mode 100644
index 000000000000..1329ada5712f
--- /dev/null
+++ b/games-puzzle/cuyo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<use>
+ <flag name="music">Enable playing of background music</flag>
+</use>
+</pkgmetadata>