summaryrefslogtreecommitdiff
path: root/games-puzzle/einstein/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
commit7c7c2c9727d6b2ff30945b5aea0d575e1c406d8b (patch)
treebac2a67fb24ac0836147fe370d30e1610ae1845d /games-puzzle/einstein/files
parent2f8db31405fac68eea6f7257d58529243815033b (diff)
gentoo resync : 02.05.2018
Diffstat (limited to 'games-puzzle/einstein/files')
-rw-r--r--games-puzzle/einstein/files/einstein-2.0-64bit.patch31
-rw-r--r--games-puzzle/einstein/files/einstein-2.0-as-needed.patch4
-rw-r--r--games-puzzle/einstein/files/einstein-2.0-gcc43.patch20
3 files changed, 2 insertions, 53 deletions
diff --git a/games-puzzle/einstein/files/einstein-2.0-64bit.patch b/games-puzzle/einstein/files/einstein-2.0-64bit.patch
deleted file mode 100644
index 4d6656252898..000000000000
--- a/games-puzzle/einstein/files/einstein-2.0-64bit.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- einstein-2.0.orig/formatter.cpp
-+++ einstein-2.0/formatter.cpp
-@@ -58,7 +58,7 @@
- if ((c.type == INT_ARG) || (c.type == STRING_ARG) ||
- (c.type == FLOAT_ARG) || (c.type == DOUBLE_ARG))
- {
-- int no = (int)c.data;
-+ long int no = (long int)c.data;
- args[no - 1] = c.type;
- }
- }
-@@ -123,7 +123,7 @@
- std::wstring Formatter::format(std::vector<ArgValue*> &argValues) const
- {
- std::wstring s;
-- int no;
-+ long int no;
-
- for (int i = 0; i < commandsCnt; i++) {
- Command *cmd = &commands[i];
-@@ -135,8 +135,8 @@
-
- case STRING_ARG:
- case INT_ARG:
-- no = (int)cmd->data - 1;
-- if (no < (int)argValues.size())
-+ no = (long int)cmd->data - 1;
-+ if (no < (long int)argValues.size())
- s += argValues[no]->format(cmd);
- break;
-
diff --git a/games-puzzle/einstein/files/einstein-2.0-as-needed.patch b/games-puzzle/einstein/files/einstein-2.0-as-needed.patch
index fe870bf036e7..3edb666ad690 100644
--- a/games-puzzle/einstein/files/einstein-2.0-as-needed.patch
+++ b/games-puzzle/einstein/files/einstein-2.0-as-needed.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2009-02-09 16:37:58.000000000 +0100
-+++ Makefile 2009-02-09 16:38:13.000000000 +0100
+--- a/Makefile.old 2009-02-09 16:37:58.000000000 +0100
++++ b/Makefile 2009-02-09 16:38:13.000000000 +0100
@@ -49,7 +49,7 @@
diff --git a/games-puzzle/einstein/files/einstein-2.0-gcc43.patch b/games-puzzle/einstein/files/einstein-2.0-gcc43.patch
deleted file mode 100644
index 25e1815e5e41..000000000000
--- a/games-puzzle/einstein/files/einstein-2.0-gcc43.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- einstein-2.0.orig/convert.h
-+++ einstein-2.0/convert.h
-@@ -5,6 +5,7 @@
- #include <iostream>
- #include <sstream>
- #include <string>
-+#include <typeinfo>
-
- #include "exceptions.h"
- #include "unicode.h"
-
---- einstein-2.0.orig/unicode.cpp
-+++ einstein-2.0/unicode.cpp
-@@ -1,5 +1,6 @@
- #include <wchar.h>
- #include <stdlib.h>
-+#include <string.h>
- #ifdef WIN32
- #include <windows.h>
- #endif