summaryrefslogtreecommitdiff
path: root/games-puzzle/glightoff/glightoff-1.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-puzzle/glightoff/glightoff-1.0.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-puzzle/glightoff/glightoff-1.0.0-r1.ebuild')
-rw-r--r--games-puzzle/glightoff/glightoff-1.0.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-puzzle/glightoff/glightoff-1.0.0-r1.ebuild b/games-puzzle/glightoff/glightoff-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..6eaba0d97d5f
--- /dev/null
+++ b/games-puzzle/glightoff/glightoff-1.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="A simple (but not so easy to solve!) puzzle game"
+HOMEPAGE="http://glightoff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ gnome-base/librsvg
+ media-libs/libpng:0=
+ >=x11-libs/gtk+-2.6:2
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix broken png files
+ pngfix -q --out=out.png glightoff.png
+ mv -f out.png glightoff.png || die
+
+ epatch "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+
+ gnome2_src_prepare
+}