summaryrefslogtreecommitdiff
path: root/games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild')
-rw-r--r--games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild b/games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild
new file mode 100644
index 000000000000..eece76f8cc06
--- /dev/null
+++ b/games-puzzle/gtkballs/gtkballs-3.1.5-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="An entertaining game based on the old DOS game lines"
+HOMEPAGE="http://gtkballs.antex.ru/"
+SRC_URI="http://gtkballs.antex.ru/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.10.38 )
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^nlsdir=/s:=.*:=/usr/share/locale:' \
+ -e '/^localedir/s:=.*:=/usr/share/locale:' \
+ configure po/Makefile.in.in || die "sed locale failed"
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ newicon gnome-gtkballs.png ${PN}.png
+ make_desktop_entry gtkballs "GTK Balls"
+}