summaryrefslogtreecommitdiff
path: root/games-puzzle/icebreaker/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/icebreaker/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/icebreaker/files')
-rw-r--r--games-puzzle/icebreaker/files/icebreaker-1.9.6-gentoo.patch247
-rw-r--r--games-puzzle/icebreaker/files/icebreaker-1.9.6-ldflags.patch28
-rw-r--r--games-puzzle/icebreaker/files/icebreaker-1.9.6-ovfl.patch20
-rw-r--r--games-puzzle/icebreaker/files/icebreaker-1.9.6-parallell-install.patch34
4 files changed, 329 insertions, 0 deletions
diff --git a/games-puzzle/icebreaker/files/icebreaker-1.9.6-gentoo.patch b/games-puzzle/icebreaker/files/icebreaker-1.9.6-gentoo.patch
new file mode 100644
index 000000000000..846d5b4141bc
--- /dev/null
+++ b/games-puzzle/icebreaker/files/icebreaker-1.9.6-gentoo.patch
@@ -0,0 +1,247 @@
+--- a/dialog.c
++++ b/dialog.c
+@@ -279,10 +279,10 @@ PopupReturnType popuphighscores()
+
+ for (i=0;i<HISCORENUM;i++)
+ {
+- snprintf(buf,4,"%d.",i+1);
++ snprintf(buf,sizeof(buf),"%d.",i+1);
+ puttext(scorelistrect.x+BLOCKWIDTH,scorelistrect.y+45+i*(CHARHEIGHT*2+5),2,color.normaltext,buf);
+ puttext(scorelistrect.x+BLOCKWIDTH*4,scorelistrect.y+45+i*(CHARHEIGHT*2+5),2,color.normaltext,hiscorename[i]);
+- snprintf(buf,30,"%ld",hiscoreval[i]);
++ snprintf(buf,sizeof(buf),"%ld",hiscoreval[i]);
+ puttext(scorelistrect.x+scorelistrect.w-(BLOCKWIDTH*5),scorelistrect.y+45+i*(CHARHEIGHT*2+5),2,color.normaltext,buf);
+ }
+
+@@ -364,7 +364,7 @@ PopupReturnType popuphelp()
+ {
+ puttext(helprect.x+BLOCKWIDTH/2,helprect.y+BLOCKHEIGHT/2+i*(CHARHEIGHT*2+4),2,color.normaltext,helptext[i]);
+ }
+- snprintf(buf,80,"v%d.%d.%d %s",VERMAJOR,VERMINOR,VERSUB,"Copyright (c) 2000-2002 Matthew Miller. Released under the GPL.");
++ snprintf(buf,sizeof(buf),"v%d.%d.%d %s",VERMAJOR,VERMINOR,VERSUB,"Copyright (c) 2000-2002 Matthew Miller. Released under the GPL.");
+ puttext(helprect.x+BLOCKWIDTH/2,helprect.y+helprect.h-CHARHEIGHT*3,1,color.copyrighttext,buf);
+ puttext(helprect.x+BLOCKWIDTH/2,helprect.y+helprect.h-CHARHEIGHT*1-3,1,color.copyrighttext,"Thanks to my wonderful wife Karen for inspiration (and for patience)!");
+
+--- a/menu.c
++++ b/menu.c
+@@ -193,12 +193,12 @@ PopupReturnType popupoptionsmenu()
+
+ if (strlen(commandline.theme)>0)
+ {
+- snprintf(originaltheme,MAXTHEMENAMELENGTH+1,"%s",commandline.theme);
++ snprintf(originaltheme,sizeof(originaltheme),"%s",commandline.theme);
+ originalthemecl=true;
+ }
+ else
+ {
+- snprintf(originaltheme,MAXTHEMENAMELENGTH+1,"%s",options.theme);
++ snprintf(originaltheme,sizeof(originaltheme),"%s",options.theme);
+ originalthemecl=false;
+ }
+
+@@ -521,7 +521,7 @@ PopupReturnType menuitem_theme(char * va
+ if (((mbutton==1 || mbutton==4) && t==themecount-1) || ((mbutton!=1 && mbutton!=4) && t==0))
+ { // "random", at the end/beginning of the list
+
+- strncpy(val,"random",MAXMENUVALUELENGTH);
++ strcpy(options.theme,"random");
+ snprintf(options.theme,MAXMENUVALUELENGTH,"random");
+
+ settheme("linux"); // just for pretty
+@@ -538,7 +538,7 @@ PopupReturnType menuitem_theme(char * va
+ if (mbutton==1 || mbutton==4) // left click or scroll forwards
+ {
+ strncpy(val,themelist[(t+1)%themecount],MAXMENUVALUELENGTH);
+- snprintf(options.theme,MAXMENUVALUELENGTH,themelist[(t+1)%themecount]);
++ snprintf(options.theme,sizeof(options.theme),"%s",themelist[(t+1)%themecount]);
+ }
+ else // right or middle or scroll back
+ {
+--- a/hiscore.c
++++ b/hiscore.c
+@@ -72,7 +72,7 @@
+ // make sure all entries are zeroed out to start.
+ for (i=0;i<HISCORENUM;i++)
+ {
+- snprintf(temphiscorename[i],7,"Nobody");
++ strcpy(temphiscorename[i],"Nobody");
+ temphiscoreval[i]=100; //100 is better than 0. :)
+ }
+
+@@ -103,7 +103,7 @@
+ // ok, so now, we can copy things over in the proper sorted order
+ for (i=0;i<HISCORENUM;i++)
+ {
+- snprintf(hiscorename[i],50,temphiscorename[arrayindex[i]]);
++ snprintf(hiscorename[i],50,"%s",temphiscorename[arrayindex[i]]);
+ hiscoreval[i]=temphiscoreval[arrayindex[i]];
+ }
+
+@@ -201,13 +201,13 @@
+ // make sure the temp array contains the right data
+ for (i=0;i<HISCORENUM;i++)
+ {
+- snprintf(temphiscorename[i],50,hiname[i]);
++ snprintf(temphiscorename[i],50,"%s",hiname[i]);
+ temphiscoreval[i]=hival[i];
+ }
+
+ // and toss in the new data
+ //(this is why these arrays are size HISCORENUM+1)
+- snprintf(temphiscorename[HISCORENUM],50,username);
++ snprintf(temphiscorename[HISCORENUM],50,"%s",username);
+ temphiscoreval[HISCORENUM]=score;
+
+ // fill the "helper" array.
+@@ -221,7 +221,7 @@
+ // and take the top ones back.
+ for (i=0;i<HISCORENUM;i++)
+ {
+- snprintf(hiname[i],50,temphiscorename[arrayindex[i]]);
++ snprintf(hiname[i],50,"%s",temphiscorename[arrayindex[i]]);
+ hival[i]=temphiscoreval[arrayindex[i]];
+ }
+ }
+--- a/line.c
++++ b/line.c
+@@ -30,8 +30,9 @@
+
+ Line createline(int linenum)
+ {
+- Line l;
++ static Line l;
+
++ memset(&l, 0, sizeof(l));
+ switch (linenum)
+ {
+ case 1:
+--- a/options.c
++++ b/options.c
+@@ -66,7 +66,7 @@
+ options.autopause=AUTOPAUSEOFF;
+ options.difficulty=NORMAL;
+ options.fullscreen=FULLSCREENOFF;
+- snprintf(options.theme,MAXTHEMENAMELENGTH+1,"linux");
++ strcpy(options.theme,"linux");
+ }
+
+ int readoptions(void)
+@@ -81,7 +81,7 @@
+
+ setdefaultoptions();
+
+- snprintf(filename,255,"%s/%s",homedir,OPTIONFILE);
++ snprintf(filename,sizeof(filename),"%s/%s",homedir,OPTIONFILE);
+
+ optionfile=fopen(filename,"r");
+ if (optionfile==NULL)
+@@ -135,7 +135,7 @@
+ }
+ else if (!strcmp(optbuf,"theme"))
+ {
+- snprintf(options.theme,MAXTHEMENAMELENGTH+1,"%s",valbuf);
++ snprintf(options.theme,sizeof(options.theme),"%s",valbuf);
+ }
+ // FIX: add username
+ }
+@@ -150,7 +150,7 @@
+ {
+ FILE * optionfile;
+ char filename[255];
+- snprintf(filename,255,"%s/%s",homedir,OPTIONFILE);
++ snprintf(filename,sizeof(filename),"%s/%s",homedir,OPTIONFILE);
+
+ optionfile=fopen(filename,"w");
+ if (optionfile==NULL)
+@@ -292,7 +292,7 @@
+ else
+ {
+ // fix -- we should probably search for malicious characters here.
+- snprintf(commandline.theme,MAXTHEMENAMELENGTH+1,"%s",argv[i]+strlen(FLAGTHEME));
++ snprintf(commandline.theme,sizeof(commandline.theme),"%s",argv[i]+strlen(FLAGTHEME));
+ }
+ }
+ else if (strncmp(argv[i],FLAGTHEMELONG "=" ,strlen(FLAGTHEMELONG "=")) == 0)
+@@ -312,7 +312,7 @@
+ else
+ {
+ // fix -- we should probably search for malicious characters here.
+- snprintf(commandline.theme,MAXTHEMENAMELENGTH+1,"%s",argv[i]+strlen(FLAGTHEMELONG "="));
++ snprintf(commandline.theme,sizeof(commandline.theme),"%s",argv[i]+strlen(FLAGTHEMELONG "="));
+ }
+ }
+ else if (strncmp(argv[i],FLAGTHEMELONG,strlen(FLAGTHEMELONG)) == 0)
+--- a/penguin.c
++++ b/penguin.c
+@@ -40,8 +40,9 @@
+
+ Penguin createpenguinxy(int x, int y)
+ {
+- Penguin p;
++ static Penguin p;
+
++ memset(&p, 0, sizeof(p));
+ switch (random() % 4)
+ {
+ case 0:
+--- a/themes.c
++++ b/themes.c
+@@ -183,7 +183,7 @@
+
+ foundcolor.spritetransparent = 0;
+
+- snprintf(themefilename, 256,"%s/%s%s",DATAPREFIX,themename,THEMEFILEEXTENSION);
++ snprintf(themefilename, sizeof(themefilename),"%s/%s%s",DATAPREFIX,themename,THEMEFILEEXTENSION);
+
+ themefile=fopen(themefilename,"r");
+ if (themefile==NULL)
+@@ -329,7 +329,7 @@
+ "We'll try to load it anyway, but don't be surpised if there's a problem.\n"
+ "(Filename is %s)\n",themename,valbuf);
+ }
+- snprintf(loadfilebuf, 256,"%s/%s",DATAPREFIX,valbuf);
++ snprintf(loadfilebuf, sizeof(loadfilebuf),"%s/%s",DATAPREFIX,valbuf);
+ spriteimage=loadsprite(themename,loadfilebuf);
+ }
+ else if (!strcmp(optbuf,"spritemirrorbitmap"))
+@@ -340,7 +340,7 @@
+ "We'll try to load it anyway, but don't be surpised if there's a problem.\n"
+ "(Filename is %s)\n",themename,valbuf);
+ }
+- snprintf(loadfilebuf, 256,"%s/%s",DATAPREFIX,valbuf);
++ snprintf(loadfilebuf, sizeof(loadfilebuf),"%s/%s",DATAPREFIX,valbuf);
+ spritemirrorimage=loadsprite(themename,loadfilebuf);
+ }
+ else if (!strcmp(optbuf,"soundouch"))
+@@ -351,7 +351,7 @@
+ "We'll try to load it anyway, but don't be surpised if there's a problem.\n"
+ "(Filename is %s)\n",themename,valbuf);
+ }
+- snprintf(loadfilebuf, 256,"%s/%s",DATAPREFIX,valbuf);
++ snprintf(loadfilebuf, sizeof(loadfilebuf),"%s/%s",DATAPREFIX,valbuf);
+ loadsounds(themename,loadfilebuf,NULL);
+ }
+ else if (!strcmp(optbuf,"soundcrash"))
+@@ -362,7 +362,7 @@
+ "We'll try to load it anyway, but don't be surpised if there's a problem.\n"
+ "(Filename is %s)\n",themename,valbuf);
+ }
+- snprintf(loadfilebuf, 256,"%s/%s",DATAPREFIX,valbuf);
++ snprintf(loadfilebuf, sizeof(loadfilebuf),"%s/%s",DATAPREFIX,valbuf);
+ loadsounds(themename,NULL,loadfilebuf);
+ }
+ }
+@@ -474,11 +474,11 @@
+ {
+ fprintf(stderr,"Hey! You can't have a theme named random! Please remove the random.ibt\n"
+ "file from your themes directory.\n");
+- snprintf(themename,MAXTHEMENAMELENGTH+1,"linux");
++ strcpy(themename,"linux");
+ }
+ else
+ {
+- snprintf(themename,MAXTHEMENAMELENGTH+1,themelist[random() %themecount]);
++ snprintf(themename,sizeof(themename),"%s",themelist[random() %themecount]);
+ }
+ freethemenames(&themelist,themecount);
+ return settheme(themename);
diff --git a/games-puzzle/icebreaker/files/icebreaker-1.9.6-ldflags.patch b/games-puzzle/icebreaker/files/icebreaker-1.9.6-ldflags.patch
new file mode 100644
index 000000000000..93b40fc67687
--- /dev/null
+++ b/games-puzzle/icebreaker/files/icebreaker-1.9.6-ldflags.patch
@@ -0,0 +1,28 @@
+--- a/Makefile.orig 2010-10-11 12:20:01.274684641 -0400
++++ b/Makefile 2010-10-11 12:22:02.256897083 -0400
+@@ -1,5 +1,3 @@
+-CC=gcc
+-
+ SDLCONFIG=sdl-config
+
+ ifndef prefix
+@@ -177,7 +175,7 @@
+ [ -d win32.build ] && rm -rf win32.build || true
+
+ icebreaker: $(SRC:.c=.o)
+- $(CC) $(CFLAGS) $^ -o icebreaker $(SDL_LIB)
++ $(CC) $(LDFLAGS) $(CFLAGS) $^ -o icebreaker $(SDL_LIB)
+
+ man: icebreaker.6
+
+@@ -202,8 +200,8 @@
+ install -m 644 *.wav *.bmp $(datadir)/icebreaker
+
+ install-bin: icebreaker
+- install -s -g games -m 2755 icebreaker $(bindir) || \
+- install -s -m 755 icebreaker $(bindir)
++ install -g games -m 2755 icebreaker $(bindir) || \
++ install -m 755 icebreaker $(bindir)
+ @test -g $(bindir)/icebreaker || \
+ echo -e '*** Note: icebreaker binary not installed set-group-ID "games" -- shared\n*** highscores may be impossible. (Try installing as root.)'
+
diff --git a/games-puzzle/icebreaker/files/icebreaker-1.9.6-ovfl.patch b/games-puzzle/icebreaker/files/icebreaker-1.9.6-ovfl.patch
new file mode 100644
index 000000000000..5e8ffc01d8d2
--- /dev/null
+++ b/games-puzzle/icebreaker/files/icebreaker-1.9.6-ovfl.patch
@@ -0,0 +1,20 @@
+--- a/menu.c.old 2013-06-24 22:09:11.606750080 +0200
++++ b/menu.c 2013-06-24 22:25:51.635735351 +0200
+@@ -522,7 +522,7 @@
+ { // "random", at the end/beginning of the list
+
+ strcpy(options.theme,"random");
+- snprintf(options.theme,MAXMENUVALUELENGTH,"random");
++ snprintf(options.theme,MAXTHEMENAMELENGTH,"random");
+
+ settheme("linux"); // just for pretty
+
+@@ -544,7 +544,7 @@
+ {
+ if (t<0) t=themecount;
+ strncpy(val,themelist[(t-1)%themecount],MAXMENUVALUELENGTH);
+- snprintf(options.theme,MAXMENUVALUELENGTH,themelist[(t-1)%themecount]);
++ snprintf(options.theme,MAXTHEMENAMELENGTH,"%s",themelist[(t-1)%themecount]);
+ }
+
+ settheme(options.theme);
diff --git a/games-puzzle/icebreaker/files/icebreaker-1.9.6-parallell-install.patch b/games-puzzle/icebreaker/files/icebreaker-1.9.6-parallell-install.patch
new file mode 100644
index 000000000000..419262791d98
--- /dev/null
+++ b/games-puzzle/icebreaker/files/icebreaker-1.9.6-parallell-install.patch
@@ -0,0 +1,34 @@
+--- a/Makefile.old 2010-10-19 10:26:18.000000000 +0200
++++ b/Makefile 2010-10-19 10:38:28.000000000 +0200
+@@ -196,26 +196,30 @@
+ themes-install: install-themes
+
+ install-themes:
++ mkdir -p $(datadir)/icebreaker
+ install -m 644 *.ibt $(datadir)/icebreaker
+ install -m 644 *.wav *.bmp $(datadir)/icebreaker
+
+ install-bin: icebreaker
++ mkdir -p $(bindir)
+ install -g games -m 2755 icebreaker $(bindir) || \
+ install -m 755 icebreaker $(bindir)
+ @test -g $(bindir)/icebreaker || \
+ echo -e '*** Note: icebreaker binary not installed set-group-ID "games" -- shared\n*** highscores may be impossible. (Try installing as root.)'
+
+ install-man: icebreaker.6
++ mkdir -p $(mandir)/man6
+ install -m 644 icebreaker.6 $(mandir)/man6
+
+ install-scorefile:
++ mkdir -p $(highscoredir)
+ touch $(highscoredir)/icebreaker.scores
+ chown -f games:games $(highscoredir)/icebreaker.scores && \
+ chmod 664 $(highscoredir)/icebreaker.scores || \
+ chmod 644 $(highscoredir)/icebreaker.scores
+
+
+-install: all install-mkdirs install-themes install-bin install-man install-scorefile
++install: install-themes install-bin install-man install-scorefile
+
+ %.d: %.c
+ set -e; $(CC) -M $(CFLAGS) $< \