summaryrefslogtreecommitdiff
path: root/games-puzzle/icebreaker/icebreaker-1.9.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/icebreaker/icebreaker-1.9.6-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/icebreaker/icebreaker-1.9.6-r1.ebuild')
-rw-r--r--games-puzzle/icebreaker/icebreaker-1.9.6-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-puzzle/icebreaker/icebreaker-1.9.6-r1.ebuild b/games-puzzle/icebreaker/icebreaker-1.9.6-r1.ebuild
new file mode 100644
index 000000000000..f064951fac68
--- /dev/null
+++ b/games-puzzle/icebreaker/icebreaker-1.9.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Trap and capture penguins on Antarctica"
+HOMEPAGE="http://www.mattdm.org/icebreaker/"
+SRC_URI="http://www.mattdm.org/${PN}/1.9.x/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-parallell-install.patch
+ "${FILESDIR}"/${P}-ovfl.patch
+)
+
+src_compile() {
+ emake \
+ OPTIMIZE="${CFLAGS}" \
+ prefix=/usr \
+ bindir=/usr/bin \
+ datadir=/usr/share \
+ highscoredir="/var"
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ bindir="${D}/usr/bin" \
+ datadir="${D}/usr/share" \
+ highscoredir="${D}/var" install
+
+ newicon ${PN}_48.bmp ${PN}.bmp
+ make_desktop_entry ${PN} IceBreaker /usr/share/pixmaps/${PN}.bmp
+ einstalldocs
+}