summaryrefslogtreecommitdiff
path: root/games-puzzle/mures/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /games-puzzle/mures/files
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'games-puzzle/mures/files')
-rw-r--r--games-puzzle/mures/files/mures-0.5-fix-fno-common.patch114
-rw-r--r--games-puzzle/mures/files/mures-0.5-underlink.patch14
2 files changed, 126 insertions, 2 deletions
diff --git a/games-puzzle/mures/files/mures-0.5-fix-fno-common.patch b/games-puzzle/mures/files/mures-0.5-fix-fno-common.patch
new file mode 100644
index 000000000000..b07be91c0175
--- /dev/null
+++ b/games-puzzle/mures/files/mures-0.5-fix-fno-common.patch
@@ -0,0 +1,114 @@
+--- a/src/client.c
++++ b/src/client.c
+@@ -37,7 +37,7 @@
+
+ int client_initialized = 0;
+ UDPsocket local_socket = NULL;
+-UDPpacket *packet;
++extern UDPpacket *packet;
+
+ #define PACKET_POOL_SIZE 20
+
+--- a/src/game_output.c
++++ b/src/game_output.c
+@@ -31,6 +31,11 @@
+ #include "go_sdl.h"
+ #include "go_gl.h"
+
++void (*game_output_handle_event)(game *g, int event, float x, float y, direction dir);
++void (*game_output_refresh)(game *g, SDL_Surface *out);
++void (*game_output_bigchange)(game *g);
++void (*game_output_exit)(game *g);
++
+ void game_output_init(game *g, int type)
+ {
+ switch(type) {
+--- a/src/game_output.h
++++ b/src/game_output.h
+@@ -38,10 +38,10 @@
+ GL
+ };
+
+-void (*game_output_handle_event)(game *g, int event, float x, float y, direction dir);
+-void (*game_output_refresh)(game *g, SDL_Surface *out);
+-void (*game_output_bigchange)(game *g);
+-void (*game_output_exit)(game *g);
++extern void (*game_output_handle_event)(game *g, int event, float x, float y, direction dir);
++extern void (*game_output_refresh)(game *g, SDL_Surface *out);
++extern void (*game_output_bigchange)(game *g);
++extern void (*game_output_exit)(game *g);
+
+ void game_output_init(game *g, int type);
+
+--- a/src/gi_sdl.c
++++ b/src/gi_sdl.c
+@@ -60,6 +60,7 @@
+ #define GI (*(gi_sdl_data*)g->input)
+
+ SDL_Joystick *js;
++gi_sdl_settings ks;
+
+ int gi_sdl_player_exists(game *g, int p)
+ {
+--- a/src/gi_sdl.h
++++ b/src/gi_sdl.h
+@@ -88,7 +88,7 @@
+ int joy_y[MAX_JOY];
+ } gi_sdl_settings;
+
+-gi_sdl_settings ks;
++extern gi_sdl_settings ks;
+
+ int gi_sdl_player_exists(game *g, int p);
+ grid_int_position gi_sdl_player_grid_pos(game *g, int p);
+--- a/src/gui.h
++++ b/src/gui.h
+@@ -47,6 +47,6 @@
+ void gui_remove_object(int i);
+ void gui_clear();
+
+-int factor_h, factor_w;
++extern int factor_h, factor_w;
+
+ #endif
+--- a/src/lua.c
++++ b/src/lua.c
+@@ -22,6 +22,7 @@
+ }
+ */
+
++lua_State *L;
+
+ static int lua_write(lua_State *L)
+ {
+--- a/src/lua.h
++++ b/src/lua.h
+@@ -4,7 +4,7 @@
+ #include "lua/lua.h"
+
+
+-lua_State *L;
++extern lua_State *L;
+
+ int lua_init();
+ void lua_exit();
+--- a/src/main.c
++++ b/src/main.c
+@@ -44,6 +44,7 @@
+ #include "lua.h"
+
+ root_type root;
++int opengl;
+
+ void root_quit()
+ {
+--- a/src/main.h
++++ b/src/main.h
+@@ -44,6 +44,6 @@
+
+ void root_quit();
+
+-int opengl;
++extern int opengl;
+
+ #endif
diff --git a/games-puzzle/mures/files/mures-0.5-underlink.patch b/games-puzzle/mures/files/mures-0.5-underlink.patch
index 3acf0b0f7233..614a2880cf3b 100644
--- a/games-puzzle/mures/files/mures-0.5-underlink.patch
+++ b/games-puzzle/mures/files/mures-0.5-underlink.patch
@@ -1,5 +1,15 @@
---- a/src/Makefile.am.old 2011-06-21 14:39:14.404333493 +0200
-+++ b/src/Makefile.am 2011-06-21 14:39:30.538340283 +0200
+--- a/configure.in
++++ b/configure.in
+@@ -7,6 +7,7 @@
+ AC_PROG_MAKE_SET
+ AC_PROG_CC
+ AC_PROG_RANLIB
++AM_PROG_AR
+ AC_PROG_INSTALL
+
+ dnl Checks for libraries.
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -1,8 +1,8 @@
bin_PROGRAMS = mures