summaryrefslogtreecommitdiff
path: root/games-puzzle/nudoku/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /games-puzzle/nudoku/files
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'games-puzzle/nudoku/files')
-rw-r--r--games-puzzle/nudoku/files/nudoku-2.1.0-ncurses-link.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-puzzle/nudoku/files/nudoku-2.1.0-ncurses-link.patch b/games-puzzle/nudoku/files/nudoku-2.1.0-ncurses-link.patch
new file mode 100644
index 000000000000..396dbccddccf
--- /dev/null
+++ b/games-puzzle/nudoku/files/nudoku-2.1.0-ncurses-link.patch
@@ -0,0 +1,37 @@
+Ensure we link against the correct ncurses libraries.
+https://bugs.gentoo.org/764470
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,11 +1,7 @@
+ #AM_CFLAGS = --pedantic -Wall
+ #-DDEBUG
+
+-if HAVE_WIDE_NCURSES
+-nudoku_LDADD = -lncursesw
+-else
+-nudoku_LDADD = -lncurses
+-endif
++nudoku_LDADD = ${ncurses_LIBS}
+ bin_PROGRAMS = nudoku
+ nudoku_SOURCES = main.c sudoku.c sudoku.h
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -34,15 +34,7 @@ the cairo development libraries, or compile without support (--disable-cairo)
+
+ fi
+
+-have_wide_ncurses=no
+-AC_CHECK_LIB(ncursesw, initscr, [have_wide_ncurses=yes])
+-if test $have_wide_ncurses = no; then
+- AC_CHECK_LIB(ncurses, initscr, [], [
+- echo "nudoku requires ncurses"
+- exit 1
+- ])
+-fi
+-AM_CONDITIONAL([HAVE_WIDE_NCURSES], [test $have_wide_ncurses = yes])
++PKG_CHECK_MODULES([ncurses], [ncurses])
+
+ # Checks for header files.
+ AC_CHECK_HEADERS([stdlib.h string.h unistd.h])
+