summaryrefslogtreecommitdiff
path: root/games-puzzle/nudoku/nudoku-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /games-puzzle/nudoku/nudoku-2.1.0.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'games-puzzle/nudoku/nudoku-2.1.0.ebuild')
-rw-r--r--games-puzzle/nudoku/nudoku-2.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-puzzle/nudoku/nudoku-2.1.0.ebuild b/games-puzzle/nudoku/nudoku-2.1.0.ebuild
new file mode 100644
index 000000000000..199f09b2bb1b
--- /dev/null
+++ b/games-puzzle/nudoku/nudoku-2.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="ncurses based sudoku game"
+HOMEPAGE="https://jubalh.github.io/nudoku"
+SRC_URI="https://github.com/jubalh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ cairo? ( x11-libs/cairo )
+ >=sys-devel/gettext-0.20
+ sys-libs/ncurses:=
+ virtual/libintl
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.1.0-ncurses-link.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable cairo)
+}