summaryrefslogtreecommitdiff
path: root/games-puzzle/numptyphysics/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /games-puzzle/numptyphysics/files
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'games-puzzle/numptyphysics/files')
-rw-r--r--games-puzzle/numptyphysics/files/numptyphysics-0.3.5-gentoo.patch13
-rw-r--r--games-puzzle/numptyphysics/files/numptyphysics-0.3.8-empty-tr.patch10
-rw-r--r--games-puzzle/numptyphysics/files/numptyphysics-0.3.8-respect-flags.patch30
3 files changed, 40 insertions, 13 deletions
diff --git a/games-puzzle/numptyphysics/files/numptyphysics-0.3.5-gentoo.patch b/games-puzzle/numptyphysics/files/numptyphysics-0.3.5-gentoo.patch
deleted file mode 100644
index 9a739ed5227c..000000000000
--- a/games-puzzle/numptyphysics/files/numptyphysics-0.3.5-gentoo.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/makefile b/makefile
-index 8125a48..0ee4942 100644
---- a/makefile
-+++ b/makefile
-@@ -37,7 +37,7 @@ $(OBJECTS): $(GENERATED_HEADERS)
-
- $(TARGET): $(OBJECTS) $(LOCAL_LIBS)
- $(SILENTMSG) "\tLD\t$@\n"
-- $(SILENTCMD) $(CXX) -o $@ $^ $(LIBS)
-+ $(SILENTCMD) $(CXX) -o $@ $^ $(LDFLAGS) $(LIBS)
-
- clean: $(ADDITIONAL_CLEAN_TARGETS)
- $(SILENTMSG) "\tCLEAN\n"
diff --git a/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-empty-tr.patch b/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-empty-tr.patch
new file mode 100644
index 000000000000..847092190d35
--- /dev/null
+++ b/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-empty-tr.patch
@@ -0,0 +1,10 @@
+On unrecognized LC_MESSAGES (e.g. C.utf8) the .empty() check
+fails and loads empty translations leading to constant:
+[ 1536ms] [I18n.cpp:34 WARNING] Untranslated: 'Gameplay paused'
+--- a/src/Os.cpp
++++ b/src/Os.cpp
+@@ -279,3 +279,3 @@
+ auto fn = thp::format("i18n/%s", lang);
+- if (!Config::readFile(fn).empty()) {
++ if (!access(Config::findFile(fn).c_str(),F_OK)) {
+ Tr::load(fn);
diff --git a/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-respect-flags.patch b/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-respect-flags.patch
new file mode 100644
index 000000000000..09b54e6ac739
--- /dev/null
+++ b/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-respect-flags.patch
@@ -0,0 +1,30 @@
+diff '--color=auto' -NarU 2 a/external/Box2D/Source/Makefile b/external/Box2D/Source/Makefile
+--- a/external/Box2D/Source/Makefile 2021-06-18 07:19:06.000000000 -0400
++++ b/external/Box2D/Source/Makefile 2021-07-16 17:01:57.254825075 -0400
+@@ -7,5 +7,5 @@
+ endif
+
+-CXXFLAGS= -g -O2
++CXXFLAGS ?= -g -O2
+
+ SOURCES = \
+diff '--color=auto' -NarU 2 a/makefile b/makefile
+--- a/makefile 2021-06-18 07:19:06.000000000 -0400
++++ b/makefile 2021-07-16 17:00:51.421009113 -0400
+@@ -38,5 +38,5 @@
+ $(TARGET): $(OBJECTS) $(LOCAL_LIBS)
+ $(SILENTMSG) "\tLD\t$@\n"
+- $(SILENTCMD) $(CXX) -o $@ $^ $(LIBS)
++ $(SILENTCMD) $(CXX) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+ clean: $(ADDITIONAL_CLEAN_TARGETS)
+diff '--color=auto' -NarU 2 a/mk/pkgs.mk b/mk/pkgs.mk
+--- a/mk/pkgs.mk 2021-06-18 07:19:06.000000000 -0400
++++ b/mk/pkgs.mk 2021-07-16 17:10:28.636268435 -0400
+@@ -1,4 +1,4 @@
+ ifneq ($(PKGS),)
+-CXXFLAGS += $(shell $(CROSS_COMPILE)pkg-config --cflags $(PKGS))
+-LIBS += $(shell $(CROSS_COMPILE)pkg-config --libs $(PKGS))
++CXXFLAGS += $(shell $(PKG_CONFIG) --cflags $(PKGS))
++LIBS += $(shell $(PKG_CONFIG) --libs $(PKGS))
+ endif