summaryrefslogtreecommitdiff
path: root/games-puzzle/numptyphysics/numptyphysics-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-puzzle/numptyphysics/numptyphysics-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-puzzle/numptyphysics/numptyphysics-9999.ebuild')
-rw-r--r--games-puzzle/numptyphysics/numptyphysics-9999.ebuild45
1 files changed, 19 insertions, 26 deletions
diff --git a/games-puzzle/numptyphysics/numptyphysics-9999.ebuild b/games-puzzle/numptyphysics/numptyphysics-9999.ebuild
index 01e05708917e..e9ab6b1a7e7d 100644
--- a/games-puzzle/numptyphysics/numptyphysics-9999.ebuild
+++ b/games-puzzle/numptyphysics/numptyphysics-9999.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils gnome2-utils flag-o-matic git-r3
+EAPI=7
-DESCRIPTION="Crayon Physics-like drawing puzzle game using the same excellent Box2D engine"
-HOMEPAGE="http://thp.io/2015/numptyphysics/"
+inherit git-r3 gnome2-utils toolchain-funcs
+DESCRIPTION="Crayon Physics-like drawing puzzle game using the same excellent Box2D engine"
+HOMEPAGE="https://github.com/thp/numptyphysics"
+EGIT_REPO_URI="https://github.com/thp/numptyphysics"
# This is only the SRC_URI for the user levels. The code is in git repo.
SRC_URI="user-levels? (
http://numptyphysics.garage.maemo.org/levels/butelo/butelo.npz
@@ -32,35 +33,27 @@ SRC_URI="user-levels? (
http://numptyphysics.garage.maemo.org/levels/zeez/zeez.npz
)"
-EGIT_REPO_URI="https://github.com/thp/numptyphysics"
-
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS=""
IUSE="+user-levels"
-RDEPEND="media-libs/libsdl2[opengl,video]
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/libsdl2[opengl,video]
media-libs/sdl2-image[png]
media-libs/sdl2-ttf
virtual/opengl
- dev-libs/glib:2"
-DEPEND="${DEPEND}
- virtual/pkgconfig"
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-src_unpack() {
- git-r3_src_unpack
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.5-gentoo.patch
+)
-src_prepare() {
- append-cxxflags -std=c++11 -Isrc
- sed -i '/-g -O2/d' external/Box2D/Source/Makefile \
- external/glaserl/makefile || die
- sed -i "/return thp::/s% thp::.*$%\"/usr/share/${PN}/data\";%" \
- src/Os.cpp || die
- sed -e '/CXXFLAGS +=/s/\(CXXFLAGS +=\).*\( -DAPP=.*\)/\1\2/' \
- -e '/SILENTCMD/s/$(LIBS)$/$(LDFLAGS) $(LIBS)/' \
- -i makefile || die
- eapply_user
+src_compile() {
+ tc-export CC CXX
+ emake
}
pkg_preinst() {