summaryrefslogtreecommitdiff
path: root/games-puzzle/pathological/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-puzzle/pathological/files
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-puzzle/pathological/files')
-rw-r--r--games-puzzle/pathological/files/pathological-1.1.3-build-r1.patch12
-rw-r--r--games-puzzle/pathological/files/pathological-1.1.3_p16-pygame2-compat.patch68
2 files changed, 68 insertions, 12 deletions
diff --git a/games-puzzle/pathological/files/pathological-1.1.3-build-r1.patch b/games-puzzle/pathological/files/pathological-1.1.3-build-r1.patch
deleted file mode 100644
index 48038df00036..000000000000
--- a/games-puzzle/pathological/files/pathological-1.1.3-build-r1.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Makefile.old 2019-12-25 20:55:37.932303932 +0100
-+++ b/Makefile 2019-12-25 20:55:58.584530808 +0100
-@@ -4,9 +4,6 @@
-
- all: write-highscores docs
-
--write-highscores: write-highscores.c
-- gcc -s -o write-highscores write-highscores.c
--
- docs: html/wheel.png
- html/wheel.png:
- ./makehtml
diff --git a/games-puzzle/pathological/files/pathological-1.1.3_p16-pygame2-compat.patch b/games-puzzle/pathological/files/pathological-1.1.3_p16-pygame2-compat.patch
new file mode 100644
index 000000000000..525f30438e17
--- /dev/null
+++ b/games-puzzle/pathological/files/pathological-1.1.3_p16-pygame2-compat.patch
@@ -0,0 +1,68 @@
+These are integers and use of "is" with pygame-2 ignores input events.
+
+https://bugs.gentoo.org/794211
+
+See also: pygame-2.0.1/buildconfig/pygame-stubs/constants.pyi
+--- a/pathological.py
++++ b/pathological.py
+@@ -133,3 +133,3 @@
+ if colorkey is not None:
+- if colorkey is -1:
++ if colorkey == -1:
+ colorkey = image.get_at((0,0))
+@@ -1395,6 +1395,6 @@
+ for event in pygame.event.get():
+- if event.type is QUIT:
++ if event.type == QUIT:
+ return -4
+- elif event.type is KEYDOWN:
+- if event.key is K_ESCAPE: return -3
++ elif event.type == KEYDOWN:
++ if event.key == K_ESCAPE: return -3
+ elif event.key == ord('n'): return 2
+@@ -1419,3 +1419,3 @@
+
+- elif event.type is MOUSEBUTTONDOWN:
++ elif event.type == MOUSEBUTTONDOWN:
+ if self.paused:
+@@ -1713,5 +1713,5 @@
+ for event in pygame.event.get():
+- if event.type is QUIT:
++ if event.type == QUIT:
+ return -2
+- elif event.type is KEYDOWN:
++ elif event.type == KEYDOWN:
+ if event.key == K_ESCAPE: return -1
+@@ -1744,3 +1744,3 @@
+ return 1
+- elif event.type is MOUSEBUTTONDOWN:
++ elif event.type == MOUSEBUTTONDOWN:
+ return 1
+@@ -1799,5 +1799,5 @@
+ for event in pygame.event.get():
+- if event.type is QUIT:
++ if event.type == QUIT:
+ return None
+- elif event.type is KEYUP:
++ elif event.type == KEYUP:
+ if event.key == K_LSHIFT:
+@@ -1806,3 +1806,3 @@
+ shift_state &= ~KMOD_RSHIFT
+- elif event.type is KEYDOWN:
++ elif event.type == KEYDOWN:
+ if event.key == K_LSHIFT:
+@@ -1994,3 +1994,3 @@
+ for event in pygame.event.get():
+- if event.type is QUIT:
++ if event.type == QUIT:
+ if self.curpage == 1:
+@@ -1999,3 +1999,3 @@
+ return -2
+- elif event.type is KEYDOWN:
++ elif event.type == KEYDOWN:
+ if event.key == K_F2:
+@@ -2032,3 +2032,3 @@
+ continue
+- elif event.type is MOUSEBUTTONDOWN:
++ elif event.type == MOUSEBUTTONDOWN:
+ if self.curpage == 1: