summaryrefslogtreecommitdiff
path: root/games-puzzle/pingus/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-puzzle/pingus/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/pingus/files')
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch13
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch22
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-gcc7.patch21
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch10
4 files changed, 0 insertions, 66 deletions
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch b/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
deleted file mode 100644
index ab772d8c72e9..000000000000
--- a/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-# Work around Gentoo's crippled dash
-
---- pingus-0.7.6/Makefile
-+++ pingus-0.7.6/Makefile
-@@ -39,7 +39,7 @@
- install -d "$(DESTDIR)$(BINDIR)"
-
- install -D build/pingus "$(DESTDIR)$(BINDIR)/pingus.bin"
-- echo -e "#!/bin/sh\nexec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\"" > "$(DESTDIR)$(BINDIR)/pingus"
-+ printf '%s\n%s' "#!/bin/sh" "exec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\"" > "$(DESTDIR)$(BINDIR)/pingus"
- chmod 755 "$(DESTDIR)$(BINDIR)/pingus"
-
- install-data:
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch b/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch
deleted file mode 100644
index 3c1cac5589e4..000000000000
--- a/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/src/pingus/pingus_main.cpp
-+++ b/src/pingus/pingus_main.cpp
-@@ -465,7 +465,7 @@
- void
- PingusMain::print_greeting_message()
- {
-- std::string greeting = "Welcome to Pingus "VERSION;
-+ std::string greeting = "Welcome to Pingus " VERSION;
- greeting += "!";
- std::cout << greeting << std::endl;
- for (unsigned int i = 0; i < greeting.length(); ++i)
---- a/src/pingus/screens/pingus_menu.cpp
-+++ b/src/pingus/screens/pingus_menu.cpp
-@@ -153,7 +153,7 @@
- gc.get_height()/2 - 280));
-
- gc.print_left(Fonts::pingus_small, Vector2i(gc.get_width()/2 - 400 + 25, gc.get_height()-140),
-- "Pingus "VERSION" - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
-+ "Pingus " VERSION " - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
- "See the file AUTHORS for a complete list of contributors.\n"
- "Pingus comes with ABSOLUTELY NO WARRANTY. This is free software, and you are\n"
- "welcome to redistribute it under certain conditions; see the file COPYING for details.\n");
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-gcc7.patch b/games-puzzle/pingus/files/pingus-0.7.6-gcc7.patch
deleted file mode 100644
index bf04ccd047cc..000000000000
--- a/games-puzzle/pingus/files/pingus-0.7.6-gcc7.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From df6e2f445d3e2925a94d22faeb17be9444513e92 Mon Sep 17 00:00:00 2001
-From: Jonathan Wakely <jwakely@redhat.com>
-Date: Mon, 30 Jan 2017 15:41:53 +0000
-Subject: [PATCH] Add missing header for std::function and std::bind
-
----
- src/pingus/screens/demo_session.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/pingus/screens/demo_session.cpp b/src/pingus/screens/demo_session.cpp
-index e3ec49a2c..f887e50f0 100644
---- a/src/pingus/screens/demo_session.cpp
-+++ b/src/pingus/screens/demo_session.cpp
-@@ -18,6 +18,7 @@
-
- #include <algorithm>
- #include <iostream>
-+#include <functional>
-
- #include "engine/gui/gui_manager.hpp"
- #include "engine/gui/surface_button.hpp"
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch b/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch
deleted file mode 100644
index 6d1af794b032..000000000000
--- a/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/engine/display/display.cpp
-+++ b/src/engine/display/display.cpp
-@@ -28,6 +28,7 @@
- #include "engine/display/delta/delta_framebuffer.hpp"
- #include "engine/display/null_framebuffer.hpp"
- #include "util/log.hpp"
-+#include "util/raise_exception.hpp"
-
- std::unique_ptr<Framebuffer> Display::s_framebuffer;
-