summaryrefslogtreecommitdiff
path: root/games-puzzle/tong
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/tong
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/tong')
-rw-r--r--games-puzzle/tong/Manifest6
-rw-r--r--games-puzzle/tong/files/tong-1.2-datadir.patch41
-rw-r--r--games-puzzle/tong/files/tong-1.2-fps.patch25
-rw-r--r--games-puzzle/tong/files/tong-1.2-makefile.patch28
-rw-r--r--games-puzzle/tong/metadata.xml8
-rw-r--r--games-puzzle/tong/tong-1.2-r1.ebuild44
6 files changed, 152 insertions, 0 deletions
diff --git a/games-puzzle/tong/Manifest b/games-puzzle/tong/Manifest
new file mode 100644
index 000000000000..d9fb526a8084
--- /dev/null
+++ b/games-puzzle/tong/Manifest
@@ -0,0 +1,6 @@
+AUX tong-1.2-datadir.patch 1109 BLAKE2B dfc55c8bf75942e047440ec25fb6c9d51bbaa13f3a62329a6aac4ae82283cc14fe9f3f80ad11a13f563952bb0566a4f4d8aa47d72b3bdbd031b54d584ba89642 SHA512 8f35bc65273a77ed9190bdff9acaa932ae96030092023e5282bb3edd651e51fa29f52eedfbcdaf504540b5fbc67b76364b839be20e4a93dde01fee852a8dd80e
+AUX tong-1.2-fps.patch 557 BLAKE2B 5123aab67c2552c5e0b2ba4a2ad9082b24fa6276056c22c9fe97de6f1aa725c119a85cea79ea6d9e7ebb6c13e18610dd804c776000ddf3396d22e4a07af7c902 SHA512 a29b875ad777dc912c4080d339e5e00f8087322f4e0995631eb30180d2c409b9ede0d7ac6e6aab5a194fca0ca6e405685310e5b898fefd75d74e469129242c8b
+AUX tong-1.2-makefile.patch 901 BLAKE2B 7619c3b3155c1c56f239a2c529affbd3f1e1a8a5cf738a5235f1b928a065cc1aaacc5a09000a48b55f299e6130aad707e3399d2fe22937dd44de71efea1f9bab SHA512 1e15918cbb9fa98e174e2853be5c99ff369667035371cda95756b30ea246a640be22d308f86052a355f58596b676843dbb546caf8dd1aac9a66aad4cb1f7b34a
+DIST tong-1.2.tar.gz 88028070 BLAKE2B b82b5c012f5d12953a6e84dfe38921cff2f0e244c2a9ad9ef606b5ee41c2f455dbb288ddb477f4eb96471ed3dd4cb4de2a8cea9155942c51f850d263fb22ee71 SHA512 0544f489141bba37985f1ef3c316208e3e6dacdea8f8b79f37997a9489ff5c1710fd1426e02489f8adb33bf9a1511bb9a0250122fa2054ef4a6ef203c8881261
+EBUILD tong-1.2-r1.ebuild 1011 BLAKE2B e65ec73abd842e978831156ee44cd89fc74944f2ea2dbcc2aa0894856fbcbee2f0191544c8076fb02abb7b2daa5e7cd2f2da8e5674b6b301eb98e0a4db4e0e9b SHA512 002557b55e0e4e46feedba17eee0746300d7c0ce28b7de0c13a78f292cbf662ea7517df08e0418689d9ccf2339f1cb2d940719d1c65c123fbe6dcdea07c81c0f
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/tong/files/tong-1.2-datadir.patch b/games-puzzle/tong/files/tong-1.2-datadir.patch
new file mode 100644
index 000000000000..92a8bb4c18a1
--- /dev/null
+++ b/games-puzzle/tong/files/tong-1.2-datadir.patch
@@ -0,0 +1,41 @@
+--- a/tong.cpp.orig
++++ b/tong.cpp
+@@ -202,7 +202,6 @@
+ Tetrad *tetrad, *nexttetrad;
+ Paddle *paddle;
+ Ball *ball;
+- char datadir[256];
+ input_t input;
+ int volume = MIX_MAX_VOLUME;
+
+@@ -210,7 +209,6 @@
+ volume = 24;
+ #endif
+ memset(&input, 0, sizeof(input_t));
+- strcpy(datadir, GAME_DATA_DIR);
+ if(argc>1) {
+ if(!strcmp(argv[1], "-v") || !strcmp(argv[1], "--version")) {
+ printf("%s\n", GAME_ID);
+@@ -219,10 +217,6 @@
+ "warranty; not even for MERCHANTABILITY or"
+ " FITNESS FOR A PARTICULAR PURPOSE.\n");
+ return 0;
+- } else if(!strncmp(argv[1], "-p=", 3)) {
+- strcpy(datadir, argv[1]+(3*sizeof(char)));
+- } else if(!strncmp(argv[1], "--path=", 7)) {
+- strcpy(datadir, argv[1]+(7*sizeof(char)));
+ } else {
+ printf("Usage: %s [OPTION]\n", argv[0]);
+ printf("Play TONG, a Free Software game (Tetris meets Pong)\n");
+@@ -237,11 +231,6 @@
+ #ifdef WII
+ fatInitDefault();
+ #endif
+- if (chdir(datadir)) {
+- printf("Could not chdir to %s (attempting to use current dir)\n",
+- datadir);
+- }
+-
+ if(SDL_Init(SDL_INIT_AUDIO
+ |SDL_INIT_VIDEO
+ |SDL_INIT_TIMER
diff --git a/games-puzzle/tong/files/tong-1.2-fps.patch b/games-puzzle/tong/files/tong-1.2-fps.patch
new file mode 100644
index 000000000000..86566646b8d6
--- /dev/null
+++ b/games-puzzle/tong/files/tong-1.2-fps.patch
@@ -0,0 +1,25 @@
+--- a/tong.cpp.orig
++++ b/tong.cpp
+@@ -64,6 +64,8 @@
+
+ #define DEMO_TIME 8000
+
++#define MIN_TIME 45
++
+ #define GP2X_BUTTON_UP 0
+ #define GP2X_BUTTON_UPLEFT 1
+ #define GP2X_BUTTON_LEFT 2
+@@ -1854,6 +1856,13 @@
+ SDL_Flip(screen);
+ lastlastupdate=lastupdate;
+ lastupdate=SDL_GetTicks();
++
++ // limit to 1000/MIN_TIME fps
++ if (lastupdate-lastlastupdate < MIN_TIME) {
++ SDL_Delay(MIN_TIME - (lastupdate - lastlastupdate));
++ }
++ lastupdate = SDL_GetTicks();
++
+ } //main game loop
+
+ Mix_FreeMusic(music);
diff --git a/games-puzzle/tong/files/tong-1.2-makefile.patch b/games-puzzle/tong/files/tong-1.2-makefile.patch
new file mode 100644
index 000000000000..ad9b283f4785
--- /dev/null
+++ b/games-puzzle/tong/files/tong-1.2-makefile.patch
@@ -0,0 +1,28 @@
+--- a/Makefile.orig
++++ b/Makefile
+@@ -1,11 +1,10 @@
+ # TONG! makefile, tweak as you see fit
+
+-SDL_CFLAGS := $(shell sdl-config --cflags)
++CXXFLAGS += $(shell sdl-config --cflags)
+ SDL_LDFLAGS := $(shell sdl-config --libs)
+ MIXER_FLAGS := -lSDL_mixer -lpthread
+ IMG_FLAGS := -lSDL_image
+ GAME_DATA_DIR := .
+-CC = g++ -O3 -Wall #-ggdb3
+ SOURCES = tetris.cpp pong.cpp text.cpp option.cpp media.cpp
+ # these sources need to be linked to SDL libs, so may have special flag settings
+ SDL_SOURCES = tong.cpp
+@@ -29,11 +28,7 @@
+
+ # builds all, builds the target
+ all: $(OBJS)
+- $(CC) $(SDL_LDFLAGS) $(MIXER_FLAGS) $(IMG_FLAGS) $(OBJS) -o $(TARGET)
+-%.o: %.cpp
+- $(CC) $(SDL_CFLAGS) -c -o $@ $<
+-tong.o: $(SDL_SOURCES)
+- $(CC) -DGAME_DATA_DIR=\"$(GAME_DATA_DIR)\" $(SDL_CFLAGS) -c -o $@ $<
++ $(CXX) $(LDFLAGS) $(OBJS) $(SDL_LDFLAGS) $(MIXER_FLAGS) $(IMG_FLAGS) -o $(TARGET)
+
+ # clean out the mess
+ clean:
diff --git a/games-puzzle/tong/metadata.xml b/games-puzzle/tong/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/tong/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-puzzle/tong/tong-1.2-r1.ebuild b/games-puzzle/tong/tong-1.2-r1.ebuild
new file mode 100644
index 000000000000..a16067fc57ba
--- /dev/null
+++ b/games-puzzle/tong/tong-1.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Tetris and Pong in the same place at the same time"
+HOMEPAGE="http://www.nongnu.org/tong/"
+SRC_URI="http://www.nongnu.org/tong/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}/${P}-makefile.patch" \
+ "${FILESDIR}/${P}-fps.patch" \
+ "${FILESDIR}/${P}-datadir.patch"
+ sed -i \
+ -e "s:\"media/:\"/usr/share/${PN}/media/:" \
+ media.cpp option.cpp option.h pong.cpp tetris.cpp text.cpp \
+ || die
+ cp media/icon.png "${T}/${PN}.png" || die
+}
+
+src_install() {
+ dobin tong
+ dodir "/usr/share/${PN}"
+ cp -r media/ "${ED}/usr/share/${PN}" || die
+ dodoc CHANGELOG README making-of.txt CREDITS
+
+ make_desktop_entry tong TONG
+ doicon "${T}/${PN}.png"
+}