summaryrefslogtreecommitdiff
path: root/games-puzzle/torrent/torrent-0.8.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/torrent/torrent-0.8.2-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/torrent/torrent-0.8.2-r1.ebuild')
-rw-r--r--games-puzzle/torrent/torrent-0.8.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-puzzle/torrent/torrent-0.8.2-r1.ebuild b/games-puzzle/torrent/torrent-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..76d28a5eee3a
--- /dev/null
+++ b/games-puzzle/torrent/torrent-0.8.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Match rising tiles before reaching the top to score as many points as possible"
+HOMEPAGE="http://www.shiftygames.com/torrent/torrent.html"
+SRC_URI="http://www.shiftygames.com/torrent/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-ttf
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
+ src/torrent.c \
+ || die "sed failed"
+}
+
+src_install() {
+ default
+ newicon pics/sg_icon.png ${PN}.png
+ make_desktop_entry ${PN} Torrent ${PN}
+}