summaryrefslogtreecommitdiff
path: root/games-puzzle/xblockout/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
commit1c33e521c460dc40899ce7bc919602b842ce27e2 (patch)
tree580eefad4cce1e883e7504b93352a9029b53036d /games-puzzle/xblockout/files
parent65e4244e411c4f65f55f2aa91f39e228f4c0680b (diff)
gentoo auto-resync : 05:03:2023 - 23:52:45
Diffstat (limited to 'games-puzzle/xblockout/files')
-rw-r--r--games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch b/games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch
new file mode 100644
index 000000000000..af322fedd337
--- /dev/null
+++ b/games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/899012
+--- a/configure.in
++++ b/configure.in
+@@ -127,6 +127,7 @@ dnl AC_TRY_COMPILE("Prototypes",,extern int y(int z);y(5);}y(z)int z;{,CFLA="$CF
+
+ AC_TEST_PROGRAM([
+ #include <sys/time.h>
++#include <time.h>
+ int main()
+ {
+ fd_set i,j,k ;
+@@ -151,6 +152,7 @@ AC_TEST_PROGRAM([
+ #include <signal.h>
+ #include <stdio.h>
+ #include <sys/time.h>
++#include <unistd.h>
+
+ volatile int c = 0 ;
+ void fct(i) int i ; { c++ ; signal(SIGALRM, fct) ; }