summaryrefslogtreecommitdiff
path: root/games-puzzle/xblockout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/xblockout
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/xblockout')
-rw-r--r--games-puzzle/xblockout/Manifest4
-rw-r--r--games-puzzle/xblockout/files/xblockout-1.1.6-font.patch46
-rw-r--r--games-puzzle/xblockout/metadata.xml8
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.6-r1.ebuild60
4 files changed, 118 insertions, 0 deletions
diff --git a/games-puzzle/xblockout/Manifest b/games-puzzle/xblockout/Manifest
new file mode 100644
index 000000000000..668a714270f9
--- /dev/null
+++ b/games-puzzle/xblockout/Manifest
@@ -0,0 +1,4 @@
+AUX xblockout-1.1.6-font.patch 1535 BLAKE2B 5ae0fffb0d04c69123bb0c1098bcbaf2053551530d9f7f6f001ae693d4826148d16f4793009c83b286a7c9df8669e507145e39f2c7aa6bf4638ddc1e97bab15b SHA512 f74245e8d97859fa692c82f69657a77d31e84f249b5d29e23b16f072d596e85a51800f4af4578ba194151a6d0c5b577bad7a40a95d0477f31d2ae8147bec585d
+DIST xbl-1.1.6.tar.gz 136504 BLAKE2B 253c4a950def66abaef3547596b569542ea0dcd180fa5e81a7cb581d9dc23b2038b39c1059ddd36cfc89275ef3fb2a25d174ada71ab1818e408818613559a33e SHA512 96bf0460863698136a61b43260feed0e90e7ca5b6613d54c8ca98f51557a3d235597eeab46141cd6771aa0bf4fe019c5e4291dd826338e186cc905e3837531e0
+EBUILD xblockout-1.1.6-r1.ebuild 1216 BLAKE2B 1fbed71ba49c6a5851d9934faec162692cd77250d9bf61e42cb663685b56df055ced6c7f3d0fdc776c7e8ce4595ee396a435b063f6488f1c2c848906bbab36b2 SHA512 ddc6e41fbe580d99d48dbe69407720b5dd50fdaca6ad9fe149b5d8c141373b880654f2a7dac98e1e143adaa15845eddfde52349b87128613b647253048dc7134
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch b/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch
new file mode 100644
index 000000000000..1e007494e93e
--- /dev/null
+++ b/games-puzzle/xblockout/files/xblockout-1.1.6-font.patch
@@ -0,0 +1,46 @@
+--- a/initmenu.c.old 2008-10-27 23:23:43.000000000 +0100
++++ b/initmenu.c 2008-10-27 23:22:52.000000000 +0100
+@@ -408,19 +408,17 @@
+ XCharStruct overall_return ;
+
+ m->xfont = XLoadQueryFont( x->display , opt->thefont ) ;
+- m->font = XLoadFont( x->display , opt->thefont ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font=%s\n", opt->thefont) ;
+ }
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"Some problems when loading a font... trying others\n") ;
+ m->xfont = XLoadQueryFont( x->display ,
+ "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- m->font = XLoadFont( x->display ,
+- "-*-*-*-*-*-*-*-*-*-*-*-*-*-*" ) ;
+- if ( m->font==BadAlloc || m->font==BadName || m->xfont==0 )
++ m->font = m->xfont->fid;
++ if ( m->xfont==0 )
+ {
+ fprintf(stderr,"You haven't -*-*-*-*-*-*-*-*-*-*-*-*-*-*\n");
+ fprintf(stderr,"Have you A font?\n");
+@@ -428,17 +426,17 @@
+ exit(1) ;
+ }
+ }
++ m->font = m->xfont->fid;
+ m->xfont2 = XLoadQueryFont( x->display , opt->thefont2 ) ;
+- m->font2 = XLoadFont( x->display , opt->thefont2 ) ;
+ if ( opt->verbose )
+ {
+ fprintf(stderr,"font2=%s\n", opt->thefont2) ;
+ }
+- if ( m->font2==BadAlloc || m->font2==BadName || m->xfont2==0 )
++ if ( m->xfont2==0 )
+ {
+- m->font2 = m->font ;
+ m->xfont2 = m->xfont ;
+ }
++ m->font2 = m->xfont2->fid;
+
+ xgc.background = x->back_pixel ;
+ xgc.foreground = opt->backcolor!=7 ? x->white_pixel : x->black_pixel;
diff --git a/games-puzzle/xblockout/metadata.xml b/games-puzzle/xblockout/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/xblockout/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-puzzle/xblockout/xblockout-1.1.6-r1.ebuild b/games-puzzle/xblockout/xblockout-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..71a44a6d8c39
--- /dev/null
+++ b/games-puzzle/xblockout/xblockout-1.1.6-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop flag-o-matic
+
+DESCRIPTION="X Window block dropping game in 3 Dimension"
+HOMEPAGE="http://perso.univ-lyon1.fr/thierry.excoffier/XBL/"
+SRC_URI="http://perso.univ-lyon1.fr/thierry.excoffier/XBL/xbl-${PV}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/xbl-${PV}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-font.patch
+ sed -i \
+ -e '/^CC/d' \
+ -e 's:-lm:-lm -lX11:' \
+ -e '/DGROUP_GID/d' \
+ -e "s:-g$:${CFLAGS}:" \
+ Makefile.in || die
+ # Don't know about other archs. --slarti
+ use amd64 && filter-flags "-fweb"
+
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_compile() {
+ emake \
+ USE_SETGID= \
+ SCOREDIR="/usr/share/${PN}" \
+ RESOURCEDIR="/usr/share/${PN}" \
+ LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ newbin bl xbl
+
+ insinto /usr/share/${PN}
+ newins Xbl.ad Xbl
+
+ newman xbl.man xbl.6
+ dodoc README xbl-README
+ HTML_DOCS="*.html *.gif" einstalldocs
+
+ newicon xbl-game.gif ${PN}.gif
+ make_desktop_entry xbl XBlockOut /usr/share/pixmaps/${PN}.gif
+}