summaryrefslogtreecommitdiff
path: root/games-puzzle/xye/xye-0.12.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/xye/xye-0.12.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/xye/xye-0.12.2.ebuild')
-rw-r--r--games-puzzle/xye/xye-0.12.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-puzzle/xye/xye-0.12.2.ebuild b/games-puzzle/xye/xye-0.12.2.ebuild
new file mode 100644
index 000000000000..ed474f123243
--- /dev/null
+++ b/games-puzzle/xye/xye-0.12.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Free version of the classic game Kye"
+HOMEPAGE="http://xye.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xye/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-fonts/dejavu
+ media-libs/libsdl[video]
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.2-fix-buildsystem.patch
+ "${FILESDIR}"/${PN}-0.12.2-fix-c++14.patch
+ "${FILESDIR}"/${PN}-0.12.2-fix-desktop-file.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # create symlinks for previously bundled fonts
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf /usr/share/${PN}/res/DejaVuSans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf /usr/share/${PN}/res/DejaVuSans-Bold.ttf
+}