summaryrefslogtreecommitdiff
path: root/games-puzzle/zaz/zaz-1.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
commit7c7c2c9727d6b2ff30945b5aea0d575e1c406d8b (patch)
treebac2a67fb24ac0836147fe370d30e1610ae1845d /games-puzzle/zaz/zaz-1.0.0-r1.ebuild
parent2f8db31405fac68eea6f7257d58529243815033b (diff)
gentoo resync : 02.05.2018
Diffstat (limited to 'games-puzzle/zaz/zaz-1.0.0-r1.ebuild')
-rw-r--r--games-puzzle/zaz/zaz-1.0.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-puzzle/zaz/zaz-1.0.0-r1.ebuild b/games-puzzle/zaz/zaz-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..1ea20bafcd65
--- /dev/null
+++ b/games-puzzle/zaz/zaz-1.0.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic
+
+DESCRIPTION="A puzzle game where the player has to arrange balls in triplets"
+HOMEPAGE="https://sourceforge.net/projects/zaz/"
+SRC_URI="mirror://sourceforge/zaz/${P}.tar.bz2"
+
+LICENSE="GPL-3 GPL-3+ CC-BY-SA-3.0 OFL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl[X,sound,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/ftgl
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ default
+ local x=/usr/share/gettext/po/Makefile.in.in
+ [[ -e $x ]] && cp -f $x po/ #336119
+
+ eapply "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-libs -lvorbis
+ append-cflags $(pkg-config sdl --cflags)
+ append-cxxflags $(pkg-config sdl --cflags)
+ econf \
+ --with-applicationdir=/usr/share/applications \
+ --with-icondir=/usr/share/pixmaps \
+ --localedir=/usr/share/locale \
+ $(use_enable nls)
+}