summaryrefslogtreecommitdiff
path: root/games-puzzle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-05 19:20:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-05 19:20:12 +0100
commita4e37a9aeeef82eba5858dbc609f65b838b0f836 (patch)
treee4348e571adc5713a413fbaf411d45c511a7da31 /games-puzzle
parentd03ec6c0e9c1683a824ce77667440dcb4a13974e (diff)
gentoo auto-resync : 05:10:2022 - 19:20:12
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/Manifest.gzbin17468 -> 17468 bytes
-rw-r--r--games-puzzle/torrent/Manifest3
-rw-r--r--games-puzzle/torrent/files/torrent-0.8.2-Fix-function-prototypes-inline-link-issue.patch330
-rw-r--r--games-puzzle/torrent/torrent-0.8.2-r2.ebuild (renamed from games-puzzle/torrent/torrent-0.8.2-r1.ebuild)22
4 files changed, 345 insertions, 10 deletions
diff --git a/games-puzzle/Manifest.gz b/games-puzzle/Manifest.gz
index 5aa8f46cd85c..ba8e0f9b8498 100644
--- a/games-puzzle/Manifest.gz
+++ b/games-puzzle/Manifest.gz
Binary files differ
diff --git a/games-puzzle/torrent/Manifest b/games-puzzle/torrent/Manifest
index 3c94238a4674..ef18e0d701c8 100644
--- a/games-puzzle/torrent/Manifest
+++ b/games-puzzle/torrent/Manifest
@@ -1,3 +1,4 @@
+AUX torrent-0.8.2-Fix-function-prototypes-inline-link-issue.patch 9346 BLAKE2B 8d4fed551b7d59437049a6a8fce1595854ede5e8d0c915890484630a755447e9db8f4c1f96857ab2111ad0a87462d5e5b3aeb32b41ee153562c6cd907aa2f109 SHA512 f3b3fa08a209bc5450e9750581c4a176cedb9450eae4adcbc00aa691a372893823b6f9ceaae760c51350ab616362fe8b186988f6cd838bebc1dc57fbb88edba8
DIST torrent-0.8.2.tar.gz 555686 BLAKE2B 17834483730fc9e4771899fed12b687568502e857e1f00355174944c2bf21a10065a762af801df556eead7248c74883c98e7732a2c5a6f377c88605024764ba8 SHA512 da7fbb21252a76fcd41c0b22ae4c0835e2fcabc4da5ce60ad04880c3fb633b6aaa951532ac0ce69d93f03b7608e4b110a23ed6f9f8839d053cd4a0d9500d1692
-EBUILD torrent-0.8.2-r1.ebuild 775 BLAKE2B 8619a1abb32de986396aede59561a6ab48c3aea9f519eace238d4adbd4994452d390c74569cefeb95ee08ce618a01917a77c7689869af593df926f9ad066cadb SHA512 87028937ce1e635c1999861052bf2ec465df90583e5f20444f978c5cb583d57c265e1618598ed3c801b5fd2479b8b1ca40c28abdfda9d6e6ff0274fdf74a3bdc
+EBUILD torrent-0.8.2-r2.ebuild 822 BLAKE2B 2005b0d264e34540b2eb9e19e4d4c38a2ca700c200ecfd82f006690f44265df2c23fcb7c27d55c49e84e9e3c818163ef351c3a0d1027ecb907f3e8544d707e17 SHA512 3e0344afccce4fc5a1f676c34d2ab7c33dca06e3aab0ad503662da6d6bc9f22c48a0ae0e4e999968d15b7236e11c13356342732347e0c8ffc0d2b04dde74bfc6
MISC metadata.xml 250 BLAKE2B 8d44bd4c6e7d6491273e2015e36ddac74af7b94a124fd240ff030e16430f5c85e53ab812f0e3e94bb2e6d138f39b512bbe01ff98b0081cacc21a02d648ec7643 SHA512 80ac07a3cac10ad2e72e9989a130b7d2073934fe92914a9db2af4d0e769d4bf537770f8faba0654bbd64a7e85ee38cf1f9d03b4b9cd322864b1b2bb35087d610
diff --git a/games-puzzle/torrent/files/torrent-0.8.2-Fix-function-prototypes-inline-link-issue.patch b/games-puzzle/torrent/files/torrent-0.8.2-Fix-function-prototypes-inline-link-issue.patch
new file mode 100644
index 000000000000..4246faa38e3c
--- /dev/null
+++ b/games-puzzle/torrent/files/torrent-0.8.2-Fix-function-prototypes-inline-link-issue.patch
@@ -0,0 +1,330 @@
+From 983bc81ccfb981a07945344affbe7e1116061dc1 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 5 Oct 2022 16:12:55 +0100
+Subject: [PATCH] Fix function prototypes & inline link issue
+
+--- a/src/ShiftyEngine.c
++++ b/src/ShiftyEngine.c
+@@ -49,7 +49,7 @@ struct SE_Button * se_buttonList = 0;
+ int se_true = 0;
+ int se_false = 1;
+
+-extern void SE_CheckEvents();
++extern void SE_CheckEvents(void);
+
+ int SOUND_X = 0;
+ int SOUND_Y = 0;
+@@ -72,7 +72,7 @@ void SE_SetName(char * name)
+
+ /*****************************************************
+ ****************************************************/
+-void SE_Quit()
++void SE_Quit(void)
+ {
+ SDL_FreeSurface(screen);
+ SDL_FreeSurface(background);
+@@ -98,7 +98,7 @@ void SE_SetBackground(char * name)
+
+ /*****************************************************
+ ****************************************************/
+-int SE_Init()
++int SE_Init(void)
+ {
+ putenv("SDL_VIDEO_CENTERED=1");
+
+@@ -158,7 +158,7 @@ void SE_Error(char * fmt, ...)
+
+ /*****************************************************
+ ****************************************************/
+-void SE_GameLoop()
++void SE_GameLoop(void)
+ {
+ while(1)
+ SE_CheckEvents();
+@@ -167,7 +167,7 @@ void SE_GameLoop()
+
+ /*****************************************************
+ ****************************************************/
+-void SE_RegisterButton(char * name, int x, int y, int w, int h, int * cond, void (*handle)())
++void SE_RegisterButton(char * name, int x, int y, int w, int h, int * cond, void (*handle)(void))
+ {
+ struct SE_Button * ph, * head, * t = (struct SE_Button *)malloc(sizeof(struct SE_Button));
+ if(t == NULL) {
+@@ -201,7 +201,7 @@ void SE_RegisterButton(char * name, int x, int y, int w, int h, int * cond, void
+
+ /*****************************************************
+ ****************************************************/
+-void SE_AdjustSoundLevel()
++void SE_AdjustSoundLevel(void)
+ {
+ SDL_FreeSurface(soundControl);
+
+@@ -226,7 +226,7 @@ void SE_AdjustSoundLevel()
+
+ /*****************************************************
+ ****************************************************/
+-void SE_ShowSoundIcon()
++void SE_ShowSoundIcon(void)
+ {
+ SDL_Rect dest;
+
+--- a/src/ShiftyEngine.h
++++ b/src/ShiftyEngine.h
+@@ -50,7 +50,7 @@ extern SDL_Surface * background;
+ struct SE_Button {
+ char name[16];
+ int x, y, w, h;
+- void (*handle)();
++ void (*handle)(void);
+ char over;
+ int * cond;
+ struct SE_Button * next;
+@@ -62,19 +62,19 @@ extern int volume;
+ extern int SOUND_X;
+ extern int SOUND_Y;
+
+-int SE_Init ();
++int SE_Init (void);
+ void SE_SetBackground (char * filename);
+ //void SE_CheckEvents ();
+-void SE_GameLoop ();
++void SE_GameLoop (void);
+ void SE_SetFont (char * filename, int size);
+ void SE_SetName (char * name);
+ //void SE_Print (int x, int y, char * text, SDL_Color color, TTF_Font * font);
+-void SE_RegisterButton (char * name, int x, int y, int w, int h, int * cond, void (*handler)());
++void SE_RegisterButton (char * name, int x, int y, int w, int h, int * cond, void (*handler)(void));
+ //void SE_UnregisterButton (char * name);
+-void SE_Quit ();
++void SE_Quit (void);
+ void SE_Error (char * fmt, ...);
+-void SE_AdjustSoundLevel ();
+-void SE_ShowSoundIcon ();
++void SE_AdjustSoundLevel (void);
++void SE_ShowSoundIcon (void);
+
+ #endif
+
+--- a/src/logo.c
++++ b/src/logo.c
+@@ -22,7 +22,7 @@
+
+ #include "ShiftyEngine.h"
+
+-extern void SE_Redraw();
++extern void SE_Redraw(void);
+
+ static SDL_Surface * mainScreen = 0;
+ static SDL_Surface * logo = 0;
+@@ -38,7 +38,7 @@ Sint32 ICON_H = 0;
+
+ /*****************************************************
+ ****************************************************/
+-void showIcon()
++void showIcon(void)
+ {
+ SDL_Rect dest;
+
+@@ -55,7 +55,7 @@ void showIcon()
+
+ /*****************************************************
+ ****************************************************/
+-static void showLogo()
++static void showLogo(void)
+ {
+ SDL_Rect dest;
+
+@@ -69,14 +69,14 @@ static void showLogo()
+
+ /*****************************************************
+ ****************************************************/
+-static void hideLogo()
++static void hideLogo(void)
+ {
+ logoShowing = 0;
+ }
+
+ /*****************************************************
+ ****************************************************/
+-void logoClicked()
++void logoClicked(void)
+ {
+ if(!init) {
+ SE_Error("Logo module has not been initialized yet.");
+--- a/src/logo.h
++++ b/src/logo.h
+@@ -30,8 +30,8 @@ extern Sint32 ICON_Y;
+ extern Sint32 ICON_W;
+ extern Sint32 ICON_H;
+
+-void showIcon ();
+-void logoClicked ();
++void showIcon (void);
++void logoClicked (void);
+ void initLogo (SDL_Surface * surface);
+
+ extern Uint32 logoShowing;
+--- a/src/pointer.c
++++ b/src/pointer.c
+@@ -150,7 +150,7 @@ SDL_Cursor * initCursor(const char * image[])
+
+ /*****************************************************
+ ****************************************************/
+-SDL_Cursor * getHandCursor()
++SDL_Cursor * getHandCursor(void)
+ {
+ if(!handCursor)
+ handCursor = initCursor(hand);
+@@ -159,7 +159,7 @@ SDL_Cursor * getHandCursor()
+
+ /*****************************************************
+ ****************************************************/
+-SDL_Cursor * getArrowCursor()
++SDL_Cursor * getArrowCursor(void)
+ {
+ if(!arrowCursor)
+ arrowCursor = initCursor(arrow);
+--- a/src/pointer.h
++++ b/src/pointer.h
+@@ -25,8 +25,8 @@
+
+ #include "SDL.h"
+
+-SDL_Cursor * getHandCursor ();
+-SDL_Cursor * getArrowCursor ();
++SDL_Cursor * getHandCursor (void);
++SDL_Cursor * getArrowCursor (void);
+ SDL_Cursor * surfaceToCursor (SDL_Surface * image, int hx, int hy);
+ SDL_Cursor * initCursor (const char * image[]);
+
+--- a/src/sound.c
++++ b/src/sound.c
+@@ -79,7 +79,7 @@ void setVolume(const int v)
+
+ /*****************************************************
+ ****************************************************/
+-void initMixer()
++void initMixer(void)
+ {
+ channel = 0;
+
+--- a/src/sound.h
++++ b/src/sound.h
+@@ -28,6 +28,6 @@
+ void playSound (Mix_Chunk * e);
+ Mix_Chunk * loadSound (const char * name);
+ void setVolume (const int v);
+-void initMixer ();
++void initMixer (void);
+
+ #endif
+--- a/src/torrent.c
++++ b/src/torrent.c
+@@ -28,7 +28,7 @@
+ #include "ShiftyEngine.h"
+
+ /* Forward References */
+-void SE_Redraw();
++void SE_Redraw(void);
+
+ enum Color { BLUE = 0, BLUE_BOMB, RED, RED_BOMB, GREEN, GREEN_BOMB,
+ PURPLE, PURPLE_BOMB, GOLD, GOLD_BOMB, BLANK };
+@@ -179,7 +179,7 @@ char * helpText[] = {
+
+ /*****************************************************
+ ****************************************************/
+-void quit()
++void quit(void)
+ {
+ SE_Quit();
+ }
+@@ -250,7 +250,7 @@ void setTile(struct Tile * tile, const int bomb, const int color)
+
+ /*****************************************************
+ ****************************************************/
+-void game_over()
++void game_over(void)
+ {
+ int x, y, i, cont = 1;
+ SDL_Rect dest;
+@@ -295,7 +295,7 @@ void game_over()
+ stateChanged = 1;
+ }
+
+-void jiggleBoard()
++void jiggleBoard(void)
+ {
+
+ int i, x, y;
+@@ -403,7 +403,7 @@ Uint32 mytimer(Uint32 interval, void * param)
+
+ /*****************************************************
+ ****************************************************/
+-void newBoard()
++void newBoard(void)
+ {
+ int x, y;
+
+@@ -466,7 +466,7 @@ void newBoard()
+
+ /*****************************************************
+ ****************************************************/
+-void start()
++void start(void)
+ {
+ if(running)
+ return;
+@@ -570,7 +570,7 @@ void drawText(int x, int y, char * str, TTF_Font * font, int over)
+
+ /*****************************************************
+ ****************************************************/
+-void help()
++void help(void)
+ {
+ SDL_Event event;
+ SDL_Rect src;
+@@ -742,7 +742,7 @@ Uint32 updateScore(Uint32 interval, void * param)
+
+ /*****************************************************
+ ****************************************************/
+-void empty()
++void empty(void)
+ {
+ if(!scoreTexts) {
+ struct scoreText * t;
+@@ -765,7 +765,7 @@ void empty()
+
+ /*****************************************************
+ ****************************************************/
+-void SE_Redraw()
++void SE_Redraw(void)
+ {
+ int x, y;
+ SDL_Rect dest;
+@@ -912,7 +912,7 @@ int rec_clicked(const int y, const int x, const enum Color orig, const enum Colo
+
+ /*****************************************************
+ ****************************************************/
+-void slide_over()
++void slide_over(void)
+ {
+ int x, y, i;
+ for(x = 0; x < xBSize - 1; x++) {
+@@ -940,7 +940,7 @@ void slide_over()
+
+ /*****************************************************
+ ****************************************************/
+-void drop_down()
++void drop_down(void)
+ {
+ int x, y, i;
+ for(y = 0; y < yBSize; y++) {
+@@ -1045,7 +1045,7 @@ void tileClick(const int x, const int y)
+
+ /*****************************************************
+ ****************************************************/
+-inline void SE_CheckEvents()
++void SE_CheckEvents(void)
+ {
+ SDL_Event event;
+ int x, y;
diff --git a/games-puzzle/torrent/torrent-0.8.2-r1.ebuild b/games-puzzle/torrent/torrent-0.8.2-r2.ebuild
index 76d28a5eee3a..d2d71e4406b2 100644
--- a/games-puzzle/torrent/torrent-0.8.2-r1.ebuild
+++ b/games-puzzle/torrent/torrent-0.8.2-r2.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit desktop
+EAPI=8
+
+inherit autotools desktop
DESCRIPTION="Match rising tiles before reaching the top to score as many points as possible"
HOMEPAGE="http://www.shiftygames.com/torrent/torrent.html"
SRC_URI="http://www.shiftygames.com/torrent/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
+KEYWORDS="~amd64 ~x86"
RDEPEND="
>=media-libs/libsdl-1.2.4
@@ -21,16 +21,20 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.2-Fix-function-prototypes-inline-link-issue.patch
+)
+
src_prepare() {
default
- sed -i \
- -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
- src/torrent.c \
- || die "sed failed"
+
+ # Needed for Clang 16+ to flush out stale configure
+ eautoreconf
}
src_install() {
default
+
newicon pics/sg_icon.png ${PN}.png
make_desktop_entry ${PN} Torrent ${PN}
}