summaryrefslogtreecommitdiff
path: root/games-roguelike/scourge/scourge-0.21.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /games-roguelike/scourge/scourge-0.21.1-r1.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'games-roguelike/scourge/scourge-0.21.1-r1.ebuild')
-rw-r--r--games-roguelike/scourge/scourge-0.21.1-r1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/games-roguelike/scourge/scourge-0.21.1-r1.ebuild b/games-roguelike/scourge/scourge-0.21.1-r1.ebuild
index 6f23afbb4196..5eeec7c52315 100644
--- a/games-roguelike/scourge/scourge-0.21.1-r1.ebuild
+++ b/games-roguelike/scourge/scourge-0.21.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils wxwidgets
+inherit autotools desktop wxwidgets
DESCRIPTION="A graphical rogue-like adventure game"
HOMEPAGE="https://sourceforge.net/projects/scourge/"
@@ -25,14 +25,16 @@ RDEPEND="
virtual/opengl
virtual/glu"
DEPEND="${RDEPEND}
- sys-devel/gettext"
+ sys-devel/gettext
+ virtual/pkgconfig"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
PATCHES=(
"${FILESDIR}"/${P}-gcc47.patch
"${FILESDIR}"/${P}-gcc6.patch
"${FILESDIR}"/${P}-automake-1.13.patch
+ "${FILESDIR}"/${P}-freetype_pkgconfig.patch
)
src_prepare() {
@@ -50,9 +52,11 @@ src_prepare() {
}
src_configure() {
- econf \
- --with-data-dir=/usr/share/${PN} \
+ local myeconfargs=(
+ --with-data-dir=/usr/share/${PN}
--localedir=/usr/share/locale
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {