summaryrefslogtreecommitdiff
path: root/games-rpg/asphyxia
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /games-rpg/asphyxia
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'games-rpg/asphyxia')
-rw-r--r--games-rpg/asphyxia/Manifest3
-rw-r--r--games-rpg/asphyxia/asphyxia-1.0.ebuild42
-rw-r--r--games-rpg/asphyxia/metadata.xml8
3 files changed, 53 insertions, 0 deletions
diff --git a/games-rpg/asphyxia/Manifest b/games-rpg/asphyxia/Manifest
new file mode 100644
index 000000000000..0ae33dbea0df
--- /dev/null
+++ b/games-rpg/asphyxia/Manifest
@@ -0,0 +1,3 @@
+DIST Asphyxia-1.0-linux.tar 282880294 BLAKE2B cb27797413238c2e828232d46626889379ee8e9b10bc224812215e811927f50d640d520a3c399d3b58da12a5d6e6957020f89c70629c037f5334e8dca8706ba5 SHA512 9e28fe4b961a03b89b717589d7ba223374dfa12710a1f101b61c913a50dc750a6c2c8733d9b312001c92b6eeb58903028eec8e7a0b62de3f52f56eef6971e07e
+EBUILD asphyxia-1.0.ebuild 1061 BLAKE2B 59f45146111481f34bf61fd47fcb907ab6abfd1d6fd69883d9e7dfdb374b890571d581ae8783855713e6330de718d8d9763e2b3122fff57cbde9c28c3d9dfa5d SHA512 2fc1c22a18320cefc9add6561fa5fb02d079e05f168f3b983e4fbe71260b7c9c8a9542bf18007c164d0025ece872439ba7cb7a418e5f331f5eddf4c6d766326a
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-rpg/asphyxia/asphyxia-1.0.ebuild b/games-rpg/asphyxia/asphyxia-1.0.ebuild
new file mode 100644
index 000000000000..979aa1a146d9
--- /dev/null
+++ b/games-rpg/asphyxia/asphyxia-1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+RENPY_SLOT="6.99"
+MY_PN="Asphyxia"
+
+DESCRIPTION="Visual novel where the main character has one day to make peace with her friend"
+HOMEPAGE="https://ebihime.itch.io/${PN}"
+SRC_URI="${MY_PN}-${PV}-linux.tar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+RDEPEND="games-engines/renpy:${RENPY_SLOT}"
+
+S="${WORKDIR}/${MY_PN}-${PV}-linux"
+
+pkg_nofetch() {
+ einfo "If you have ${SRC_URI} as distributed by Humble Bundle then move"
+ einfo "it to your distfiles directory. If you have some other version then"
+ einfo "please contact the Gentoo Games team."
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r game/*
+
+ make_wrapper ${PN} "renpy-${RENPY_SLOT} '${EPREFIX}/usr/share/${PN}'"
+ newicon -s 48 icon.png ${PN}.png
+ make_desktop_entry ${PN} "${MY_PN}"
+
+ docinto html
+ dodoc README.html
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-rpg/asphyxia/metadata.xml b/games-rpg/asphyxia/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-rpg/asphyxia/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>