summaryrefslogtreecommitdiff
path: root/games-rpg/coe2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-rpg/coe2
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-rpg/coe2')
-rw-r--r--games-rpg/coe2/Manifest2
-rw-r--r--games-rpg/coe2/coe2-2007-r2.ebuild (renamed from games-rpg/coe2/coe2-2007-r1.ebuild)46
2 files changed, 28 insertions, 20 deletions
diff --git a/games-rpg/coe2/Manifest b/games-rpg/coe2/Manifest
index 10dab3410667..bc9270166954 100644
--- a/games-rpg/coe2/Manifest
+++ b/games-rpg/coe2/Manifest
@@ -1,3 +1,3 @@
DIST coe2_2007.zip 4937222 BLAKE2B 4640e7819d0e000b3e355f20f364f84d0cc899acd27e33bae95cece843a724918b8a3cc6a538d39478cf5070fd71658637dbc127534d5182a914f6d0f56faff0 SHA512 db0d4ee2016ef3cf7159c227c494346fa0a0e9f9b20a6b520b67899570e3135a4286d6ada2f85d7ea7b55a1baeada41654d4fab29f5996357608f0d2d654b2ed
-EBUILD coe2-2007-r1.ebuild 1368 BLAKE2B 9e0e5391d3fc5d20ee72a8020b69bacffec76859648112363dbac0b42db0818b0c856a244396036a40287444ebd914616481ed1ee64b24bcb87af40fc08865ad SHA512 03d06937428ca48eac60c03ffc6c747c0849635bfc890ad1baac807007248a4ef61e99520056aadba261e26c8e7961dd18edcd86419c979ecc6704ed85e180ec
+EBUILD coe2-2007-r2.ebuild 1375 BLAKE2B fd8a8116058ab4a886009a3b5e9fc069e43790726146f8c6b8e4b2124ed4eb1eeb8d41ec3781fb8bed851faec80197fd9d24d737c2b3fa7a1ae8a07230793b4e SHA512 3085c4c903e698e94b757d2a9743ef142c2ed959fa8753b16dd83dc4b700065f5f2a457857773678f3ab079a6128436dadef5b501d58e4ee580c3b725b667aa0
MISC metadata.xml 1166 BLAKE2B 344379ff270c13113da4d40e916e8c16505653451d93fdc82ccbb9e0c39585863056030959579f310cb6ab9a01e058d929abc3c28f9886f32d086074dfe874d6 SHA512 60a33d86c244ce321427d325d4f1fb56846940a1ab2b6c965afb317c497b142644574b94bc715fd0d602628d8b07ba9690f5d0addad626163273cc1584ada370
diff --git a/games-rpg/coe2/coe2-2007-r1.ebuild b/games-rpg/coe2/coe2-2007-r2.ebuild
index 99a3f1b823f2..3ac7358ce27a 100644
--- a/games-rpg/coe2/coe2-2007-r1.ebuild
+++ b/games-rpg/coe2/coe2-2007-r2.ebuild
@@ -1,29 +1,33 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=7
+
+inherit desktop wrapper
DESCRIPTION="Precursor to the Dominions series"
HOMEPAGE="https://www.shrapnelgames.com/Our_Games/Free_Games.html"
SRC_URI="https://download.shrapnelgames.com/downloads/${PN}_${PV}.zip"
+S="${WORKDIR}"/coe
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RESTRICT="mirror bindist"
-RDEPEND="media-libs/libsdl[sound,video]"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/coe
+DEPEND="media-libs/libsdl[sound,video]"
+RDEPEND="
+ ${DEPEND}
+ acct-group/gamestat
+"
+BDEPEND="app-arch/unzip"
# bug #430026
-QA_PREBUILT="${GAMES_PREFIX_OPT}/coe2/coe_linux"
+QA_PREBUILT="opt/coe2/coe_linux"
src_prepare() {
+ default
+
rm -r *.{dll,exe} old || die
if use amd64 ; then
mv -f coe_linux64bit coe_linux || die
@@ -31,25 +35,29 @@ src_prepare() {
}
src_install() {
- insinto "${GAMES_PREFIX_OPT}/${PN}"
+ insinto /opt/${PN}
doins *.{bgm,smp,trp,trs,wrl}
dodoc history.txt manual.txt readme.txt
- exeinto "${GAMES_PREFIX_OPT}/${PN}"
+ exeinto /opt/${PN}
doexe coe_linux
- games_make_wrapper ${PN} "./coe_linux" "${GAMES_PREFIX_OPT}/${PN}"
+ make_wrapper ${PN} "./coe_linux" "/opt/${PN}"
make_desktop_entry ${PN} "Conquest of Elysium 2"
# Slots for saved games.
# The game shows e.g. "EMPTY SLOT 0?", but it works.
- local f slot state_dir=${GAMES_STATEDIR}/${PN}
- dodir "${state_dir}"
+ local state_dir=/var/lib/${PN}
+ dodir ${state_dir}
+
+ local f slot
for slot in {0..4} ; do
f=save${slot}
- dosym "${state_dir}/save${slot}" "${GAMES_PREFIX_OPT}/${PN}/${f}"
- echo "empty slot ${slot}" > "${D}${state_dir}/${f}" || die
- fperms 660 "${state_dir}/${f}"
+
+ dosym ${state_dir}/save${slot} /opt/${PN}/${f}
+ echo "empty slot ${slot}" > "${ED}"/${state_dir}/${f} || die
+ fperms 660 ${state_dir}/${f}
done
- prepgamesdirs
+ fowners -R root:gamestat /var/lib/${PN}/
+ fperms g+s /opt/${PN}/coe_linux
}