summaryrefslogtreecommitdiff
path: root/games-rpg/coe2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-rpg/coe2
reinit the tree, so we can have metadata
Diffstat (limited to 'games-rpg/coe2')
-rw-r--r--games-rpg/coe2/Manifest5
-rw-r--r--games-rpg/coe2/coe2-2007-r1.ebuild55
-rw-r--r--games-rpg/coe2/metadata.xml23
3 files changed, 83 insertions, 0 deletions
diff --git a/games-rpg/coe2/Manifest b/games-rpg/coe2/Manifest
new file mode 100644
index 000000000000..4f28ca922f62
--- /dev/null
+++ b/games-rpg/coe2/Manifest
@@ -0,0 +1,5 @@
+DIST coe2_2007.zip 4937222 SHA256 7b7c281454f3c83ba510d4223ccfb6af77fd760fcb507d7e71cf633cd86aa3bb SHA512 db0d4ee2016ef3cf7159c227c494346fa0a0e9f9b20a6b520b67899570e3135a4286d6ada2f85d7ea7b55a1baeada41654d4fab29f5996357608f0d2d654b2ed WHIRLPOOL a9c1d989dc48dc43d5c2125f4420de9bdfe23dca9758d0f8eeac5bc19eef4aab124075530bbf04da1fc80f022718564e21d4a464b49306d3d104a733c50e7259
+EBUILD coe2-2007-r1.ebuild 1359 SHA256 b7be5019e1e09d5415280b5a31b372f2ef47a4f31d44a6a812d8c3a0ab56991e SHA512 c8cb4c13e277a8ef6d7fefbf1ef2569ef0fc95aba94496787bf9d1042036306e7c67f9b65a9bb103fa83e30fc112a95cf09702dce85397c1abfc1b11a7feb8c7 WHIRLPOOL 7fee0df462fb5c6f64d5148946f87bf851af999006c47920f5a0a66953abe201154aa8c9d0ec01c7198b14e32aea30c167d0ed3ced00750cf7ab86c47478cefd
+MISC ChangeLog 2589 SHA256 ab45399677b736cf51a56cee87c5a679302f0b86e1240ec69cdb86e0ed6c2c18 SHA512 ac7671f6104d5450ff21e152af12210314ab12ed1caa986cae7a0d4bdd096571ea4e2be2401d32611956d1e1d63581151f8786868c25210f3c34fa9f6c161449 WHIRLPOOL d259a328aa1cda881393b3fc33d2e12435c7558d579fd6ed83b4afd7239beeeca30c715cf8d8dc1841ce73876546a004710867f42dadaf7f49daf26c21d27b90
+MISC ChangeLog-2015 1062 SHA256 aefc317ce2136a063c86aa5c1c73c1699f35fc7199ce32967004609f315158c4 SHA512 41b00a4b3ee948cc2835fe0e7834f4f07d5ae5e3c3e16dc865bbfaa8afb5a30ece8004c22e493d590937e869ad6578164884945deb4cfabec921b5b48abd785c WHIRLPOOL c0e9954a502e17c1d96b4039891953ced6da388c34685f8f740532eb2e060dfde0f3a27afa360fb9df14e34bc965e6970853d50f07d1ccbd6b920ccbc3430e19
+MISC metadata.xml 1166 SHA256 6341130f57b07563f424ee4725e5196bd83de526097ba218758f0a3338ee225e SHA512 60a33d86c244ce321427d325d4f1fb56846940a1ab2b6c965afb317c497b142644574b94bc715fd0d602628d8b07ba9690f5d0addad626163273cc1584ada370 WHIRLPOOL 06aefaaa95fc1397ed646d4a6614e6b2da7e55b66b91f51ba162dc30b08a67dd69686bc7cbc55ecb1733b18abb24e57525f84e06b65eb4867a9654022c749e9a
diff --git a/games-rpg/coe2/coe2-2007-r1.ebuild b/games-rpg/coe2/coe2-2007-r1.ebuild
new file mode 100644
index 000000000000..d4070f0433ac
--- /dev/null
+++ b/games-rpg/coe2/coe2-2007-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Precursor to the Dominions series"
+HOMEPAGE="http://www.shrapnelgames.com/Illwinter/CoE2/"
+SRC_URI="http://download.shrapnelgames.com/downloads/${PN}_${PV}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist"
+
+RDEPEND="media-libs/libsdl[sound,video]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/coe
+
+# bug #430026
+QA_PREBUILT="${GAMES_PREFIX_OPT}/coe2/coe_linux"
+
+src_prepare() {
+ rm -r *.{dll,exe} old || die
+ if use amd64 ; then
+ mv -f coe_linux64bit coe_linux || die
+ fi
+}
+
+src_install() {
+ insinto "${GAMES_PREFIX_OPT}/${PN}"
+ doins *.{bgm,smp,trp,trs,wrl}
+ dodoc history.txt manual.txt readme.txt
+ exeinto "${GAMES_PREFIX_OPT}/${PN}"
+ doexe coe_linux
+
+ games_make_wrapper ${PN} "./coe_linux" "${GAMES_PREFIX_OPT}/${PN}"
+ make_desktop_entry ${PN} "Conquest of Elysium 2"
+
+ # Slots for saved games.
+ # The game shows e.g. "EMPTY SLOT 0?", but it works.
+ local f slot state_dir=${GAMES_STATEDIR}/${PN}
+ dodir "${state_dir}"
+ for slot in {0..4} ; do
+ f=save${slot}
+ dosym "${state_dir}/save${slot}" "${GAMES_PREFIX_OPT}/${PN}/${f}"
+ echo "empty slot ${slot}" > "${D}${state_dir}/${f}" || die
+ fperms 660 "${state_dir}/${f}"
+ done
+
+ prepgamesdirs
+}
diff --git a/games-rpg/coe2/metadata.xml b/games-rpg/coe2/metadata.xml
new file mode 100644
index 000000000000..59ce22e6b4f8
--- /dev/null
+++ b/games-rpg/coe2/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription lang="en">
+Originally released in 1997, Conquest of Elysium II is a turn-based fantasy
+strategy game, and the precursor to the wildly popular Dominions series. As one
+of up to eight players (human, computer controlled, or a mixture) your goal, as
+suggested in the title, is very simple: total subjugation of all that do not fly
+your banner!
+
+Choose your leader from twenty distinct character classes, including brutal
+barbarians, insane necromancers, mighty maharajas, sinister shamans, and even
+the Agarthan king from Dominions 3! Each character allows new strategies for the
+player to explore. The Priestess of Baal can summon demonic creatures, change
+the weather, and sacrifice the innocent. An Enchanter can create constructs out
+of corpses, lakes, forests, and more. Barons can build siege towers, raise
+levies, and keep his subjects in line, even in times of high taxation.
+</longdescription>
+</pkgmetadata>